Impossible to see plot after version upgrade

User 875 | 4/20/2015, 7:26:22 PM

Hi all,

I did my graphlab upgrade from the version 0.3. to the version 1.0. Now I have a problem, I can not see some plots, when I try to code the examples in iPython from the official Graphlab website. For example I execute the code, which is given here: http://graphlab.com/learn/gallery/notebooks/graphanalyticsmovies.html

Some important remark. I couldn't see only the plots of graphlab. In the example above I can see both other plots, which were produced direct by matplotlib.pyplot (the distribution plots). By graphlab plot I got next object:

<pre><code>In [3]: data = graphlab.SFrame.readcsv('remote://freebaseperformances.csv', columntypehints={'year': int}) ...: data = data[data['actorname'] != '[]'] ...: data['weight'] = .5 ...: data.show() ...: [INFO] Start server at: ipc:///tmp/graphlabserver-5368 - Server binary: /usr/local/lib/python2.7/dist-packages/graphlab/unityserver - Server log: /tmp/graphlabserver1413970240.log [INFO] GraphLab Server Version: 1.0 PROGRESS: Finished parsing file /home/semenov/freebaseperformances.csv PROGRESS: Parsing completed. Parsed 156468 lines in 0.216938 secs. Out[3]:\< IPython.core.display.Javascript at 0x7f23154ef690 \></code></pre>

Comments

User 4 | 4/21/2015, 7:53:51 AM

Hi @Guforu, I think there might be an incompatibility between the versions of IPython and graphlab-create you have installed. Does this issue still persist if you upgrade to the latest version of graphlab-create? If so, can you tell me your version of ipython as well ("pip freeze | grep ipython" on a command line should provide that)?


User 875 | 4/21/2015, 8:11:06 AM

Dear Zach, first of all, I'm very sorry that such questions are present now. They are to old. My new Graphlab version is 1.3.0 and actually I don't have any error messages since I use this version. MY python version is a little bit to old - 2.7.0. I didn't see the questions about old versions problems anymore in my Draft order, thus I can't delete them. I'm very appologize about this.


User 4 | 4/21/2015, 8:12:35 AM

@Guforu No problem, I am happy to help! I am glad you are not experiencing that problem anymore. FYI, your Python version (2.7.0) should be fine as far as I know and meets our system requirements.


User 875 | 4/21/2015, 8:17:32 AM

thank you so much for your support and for your Graphlab development. We work every day with your machine learning tool


User 1768 | 5/8/2015, 10:00:05 AM

Hi, I think my question is more match with this category. I will be so appreciated if you guide me.

1- Before, when I run "show()" command, it open a browser and show me. but, suddenly whatever I try to run any 'Show()' command, it gives me this error <IPython.core.display.Javascript at 0x10990bad0> Any suggestion, just please consider that I am new in graphlab, I just follow the instruction for everything.

2- and the next question, before, although it show me the browser and 'summary' and 'table' works very well , but, whatever I click on the 'plot' tab---> select X xis---->select Y xis-----> 'show'

it didn't show anything. Why? any suggestion?


User 4 | 5/8/2015, 3:48:28 PM

Hi @naoomi, as to your questions:

  1. It sounds like you are using the 'ipynb' target for GraphLab Canvas, but perhaps you are not running IPython Notebook. The 'ipynb' target is only meant to be used in IPython Notebook. Look for a line of code that is running gl.canvas.set_target('ipynb') and remove it (or run gl.canvas.set_target('browser') to set it back to the browser target).
  2. I am not sure why it wouldn't work -- it sounds like potentially a dataset-specific but, but it's hard to tell. Try creating the equivalent plot from the Python API, and see if that works: sf.show(view='Heat Map', x='column1', y='column2').

User 1768 | 5/9/2015, 8:04:59 AM

Hi @Zach . Thanks a lot for your fast answer. I tried both. 1- it works very well. 2- yes, when I wrote this command, it works very well. But, in browser, non of the bottoms works. Do you know why? Do you think, I need to write all commands in command line to run this types of plots?


User 1768 | 5/9/2015, 8:21:26 AM

Hi @Zach again, Sorry ask you again another problem, When I run the: sf_degree.show(view='Heat Map', x='__id', y='triangle_count') It gives me this error: self.target(*self.args, **self.__kwargs) File "/Users/anaconda/lib/python2.7/site-packages/graphlab/canvas/views/heatmap.py", line 157, in create_bins self.xMin -= max(self.xMax-self.xMin, self.xMin - sliceXmin) NameError: global name 'sliceXmin' is not defined


User 4 | 5/9/2015, 4:15:58 PM

Hi @naoomi, yes, that is a known issue in 1.3. That will be fixed in the next release. Please stay tuned for an update that will fix that issue, thanks!

I am not sure why none of the plots would be working from the browser. For now, please continue to use the Python API as a workaround to see the desired plots.


User 1768 | 5/9/2015, 4:43:38 PM

Hi @Zach, yes, I try to use IPython Notebook now and using: gl.canvas.set_target('ipynb')and everything is fine with it. Thanks for your help.