Page Ranking with 4 machines!

User 1767 | 4/16/2015, 5:48:27 PM

Hi,

I've 4 machines each one has 8 cores. I've done pageranking with normal machines and it was successful, but with thiese machines I've the following problem. I've entered:

mpiexec -n 4 -hostfile ~/machines ~/graphlab/release/toolkits/graph_analytics/pagerank --powerlaw=100000

and I've following error:

Using default values Subnet ID: 0.0.0.0 Subnet Mask: 0.0.0.0 Will find first IPv4 non-loopback address matching the subnet ERROR: fibercontrol.cpp(launch:270): Check failed: b<nworkers [1 < 1] [yate:04929] * Process received signal * [yate:04929] Signal: Aborted (6) [yate:04929] Signal code: (-6) [yate:04929] [ 0] /lib/x8664-linux-gnu/libpthread.so.0(+0xf0a0) [0x7f1b16a060a0] [yate:04929] [ 1] /lib/x8664-linux-gnu/libc.so.6(gsignal+0x35) [0x7f1b13c83165] [yate:04929] [ 2] /lib/x8664-linux-gnu/libc.so.6(abort+0x180) [0x7f1b13c863e0] [yate:04929] [ 3] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank(ZN8graphlab13fibercontrol6launchEN5boost8functionIFvvEEEmNS18fixeddensebitsetILi64EEE+0x50) [0x5bd180] [yate:04929] [ 4] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank(ZN8graphlab11fibergroup6launchERKN5boost8functionIFvvEEENS18fixeddensebitsetILi64EEE+0x313) [0x5c0183] [yate:04929] [ 5] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank(ZN8graphlab19distributedcontrol4initERKSt6vectorISsSaISsEERKSstmNS12dccommtypeE+0x51a) [0x5dcdba] [yate:04929] [ 6] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank(ZN8graphlab19distributedcontrolC1Ev+0x357) [0x5de707] [yate:04929] [ 7] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank(main+0x32) [0x4e6492] [yate:04929] [ 8] /lib/x8664-linux-gnu/libc.so.6(__libcstartmain+0xfd) [0x7f1b13c6fead] [yate:04929] [ 9] /home/hduser/graphlab/release/toolkits/graphanalytics/pagerank() [0x4e862d] [yate:04929] * End of error message * [huascaran][[30688,1],0][../../../../../../ompi/mca/btl/tcp/btltcpfrag.c:216:mcabtltcpfragrecv] mcabtltcpfragrecv: readv failed: Connection reset by peer (104)


mpiexec noticed that process rank 1 with PID 4929 on node yate exited on signal 6 (Aborted).

[alpamayo][[30688,1],3][../../../../../../ompi/mca/btl/tcp/btltcpfrag.c:216:mcabtltcpfragrecv] mcabtltcpfragrecv: readv failed: Connection reset by peer (104)

I don't know what the problem is.

Thanks in advance!

Comments

User 1592 | 4/17/2015, 1:49:45 PM

Hi It seems that your machines have only one core. PowerGraph does not work on such configuration. Please switch to stronger machines.

By the way, we have recently improved the performance of GraphLab Create. On a single machine we can run PageRank on a graph of 130 billion edges and 3.5 billion vertices. What is the size of your graph? We recommend switching to GraphLab Create.


User 1768 | 4/22/2015, 4:32:27 PM

Dear @Danny, I have the same error when I run Pagerank example. and unfortunately, I can not go to Graphlab Create now. I need to expand the code of my friend in PowerGraph. My PC is not powerful and may be one single core. But, may Macbook is good enough.But, when I try to run PowerGraph in Mac, again I have some other error when I try to run myfirstapp. Stick on this apart, no way to run on virtual machine Ubuntu and no way to run on Macbook? What I need to do? Please guide me.


User 1768 | 4/23/2015, 7:56:24 AM

The problem solved. Since my host machine has multiple cores, I try to enable multiple virtual cores for VirtualBox so it can run PowerGraph inside VirtualBox. I try the suggestion of @Zach here: http://stackoverflow.com/questions/19590531/how-do-i-enable-multiple-cores-in-my-virtual-enviroment. Thanks a lot.