Fails to detect the the right version numpy

User 1725 | 4/7/2015, 7:20:58 AM

Hi, I tried an example from the <a href="https://github.com/dato-code/how-to">Git repo How to</a>, but not work.

python linechartby_date.py [WARNING] Numpy version 1.6.2 is not supported. Minimum required version: 1.8.0. Numpy support will be disabled.

I check my numpy version: py27-numpy @1.9.2 (python, math) The core utilities for the scientific library scipy for Python

Any ideas?

Comments

User 1190 | 4/7/2015, 5:50:29 PM

We use disutils.version.StrictVersion for version checking, which does not handle non-standard version strings like "1.9.2-rc" properly.

Can you paste the output of the following code for me? <pre><code> from distutils.version import StrictVersion import numpy print numpy.version print StrictVersion(numpy.version) </code></pre>

We will improve the version checking in the coming release.

As a temporary workaround, you can disable the version checking by edit graphlab/deps/init.py


User 1190 | 4/7/2015, 6:11:37 PM

Please ignore my previous comment. I thought it was a different issue, however, by taking a second look at your output, I suspect that you have multiple numpy version in your system. And 1.6.2 is the one used in the session with GraphLab Create.

Before import graphlab, please double check the numpy version in the enviornment by running the code in my previous comment, and make sure it is more than 1.8.0.


User 1725 | 4/8/2015, 8:14:42 AM

Yes, then how to change the version of numpy in Graphlab create?


User 1190 | 4/8/2015, 5:16:14 PM

if you do a pip freeze in your virtualenv, what is the numpy version? One of the following choices may work for you: 1. If you use graphlab-create inside virtualenv, and the numpy inside virtualenv is low 1.6.2, you can do pip install --upgrade numpy 2. If you use graphlab-create inside virtualenv, and you system-wide numpy is 1.9.2, you can uninstall the numpy in the virtualenv: run pip uninstall numpy inside virtualenv 3. If you are not using graphlab-create inside virtualenv, you may need to upgrade your system-wide numpy by running sudo pip install --upgrade numpy


User 1725 | 4/8/2015, 7:43:36 PM

Here is what pip freeze outputs in terminal:

pip freeze | grep numpy numpy==1.9.2

And I tried all the choices, but not work. By the way, what is virtualenv? I install GraphLab in terminal with script sudo pip install graphlab-create==1.3 as offered in the <a href="http://https://dato.com/products/create/quick-start-guide.html">quick start page</a>


User 1190 | 4/9/2015, 3:11:44 AM

Interesting... Can you show me the output of running the following code? <pre><code> from distutils.version import StrictVersion import numpy print numpy.version print StrictVersion(numpy.version) </code></pre>

In step 2 of the quick start guide, there is a tab to switch between "install system wide" and "install in virtualenv".


User 1725 | 4/12/2015, 11:10:23 AM

I re-install the graphlab create system-wide, and now it works