Product Key Not Found Error with CronTab

User 878 | 3/30/2015, 7:47:29 AM

Hi,

I am getting the following error when using crontab script to start graphlab: "[ERROR] No product key found. Please configure your product key by setting the [Product] section with 'productkey' key in /root/.graphlab/config or by setting the environment variable GRAPHLABPRODUCT_KEY to the product key. If you do not have a product key, please register for one at http://graphlab.com/register."

Please note that this error does not occur when I run the above script manually. Any help on this issue would be highly appreciated.

Thanks, Ashu

Comments

User 4 | 3/30/2015, 8:40:19 PM

Hi Ashu,

It sounds like you may be running the GraphLab Create process as a different user via cron than you normally run as when running manually. There are two ways you could work around this, though I recommend the first one since it's generally not a good idea to run as root:

  1. Configure cron to run the process as a different user, see http://stackoverflow.com/questions/1329564/how-do-i-run-a-command-as-a-different-user-from-a-root-cronjob
  2. Run the shell script to set your product key as root (it appears cron is using the root user, so running that shell script as root should set it in the right place)

Hope that helps!


User 878 | 3/30/2015, 10:26:44 PM

Thanks Zach. That was exactly the problem. I didn't know different users have separate cron jobs. It works now :)


User 4 | 3/30/2015, 10:32:24 PM

Great, glad I could help!