Build Error

User 1577 | 3/18/2015, 6:43:19 AM

Hi, when i try to build graphlab source (https://github.com/graphlab-code/graphlab) via releases i get the following error: <i class="Italic">[shlomi@r-aa-fatty09-b0 release]$ sudo make -j4 Scanning dependencies of target libbz2 Scanning dependencies of target hadoop Scanning dependencies of target eigen Scanning dependencies of target libevent [ 3%] Built target eigen [ 10%] [ 10%] [ 10%] Built target libevent Built target libbz2 Performing download step (download, verify and extract) for 'hadoop' Scanning dependencies of target libtcmalloc -- downloading... src='https://s3-us-west-2.amazonaws.com/static.graphlab.com/PowerGraph/deps/hadoop-1.0.1.tar.gz' dst='/.autodirect/mtrswgwork/shlomi/apps/graphlab/deps/hadoop/src/hadoop-1.0.1.tar.gz' timeout='none' Scanning dependencies of target opencv CMake Error at hadoop-stamp/download-hadoop.cmake:27 (message): error: downloading 'https://s3-us-west-2.amazonaws.com/static.graphlab.com/PowerGraph/deps/hadoop-1.0.1.tar.gz' failed

status_code: 1
status_string: "Unsupported protocol"
log: Protocol "https" not supported or disabled in libcurl

Closing connection -1

make[2]: * [../deps/hadoop/src/hadoop-stamp/hadoop-download] Error 1 make[1]: [CMakeFiles/hadoop.dir/all] Error 2 make[1]: ** Waiting for unfinished jobs.... Scanning dependencies of target zookeeper [ 17%] [ 20%] [ 20%] Built target opencv Built target zookeeper Built target libtcmalloc make: *** [all] Error 2 [shlomi@r-aa-fatty09-b0 release]$</i> is there anything needs to do differently?

Comments

User 6 | 3/18/2015, 6:47:33 AM

Hi Why are you compiling with sudo? it may mess up permissions, no need to compile with sudo. It seems your system does not support https? Which os are you using? Maybe this is a proxy issue? Do you have internet connectivity on the machine you are installing?

thanks


User 1577 | 3/18/2015, 6:54:13 AM

Thx Danny! i will use my user for the installation. i use Centos 6.4. i do have internet connectivity to the machine. once i go to the make configuration file and change https to http , the problem move to another package with https. is there any configuration you recommend to avoid that?


User 6 | 3/18/2015, 10:23:19 AM

We never encountered this error before. Something is weird with your machine configuration. Can you download the pacakge via curl command line shell? Maybe update your curl version?


User 1577 | 3/18/2015, 11:39:05 AM

Hi Danny, i removed the installation and cloned and configured again . it seems to work. no i am trying ot run ALS on my 4 machines and get the below error: <b class="Bold"><i class="Italic">[shlomi@r-aa-fatty09-b0 graphlab]$ /usr/mpi/gcc/openmpi-1.8.4/bin/mpiexec -n 4 -hostfile ~/machines ./release/toolkits/collaborativefiltering/als --graph alsexample/ --maxiter=3 --ncpus=1


Primary job terminated normally, but 1 process returned a non-zero exit code.. Per user-direction, the job has been aborted.


Invalid syntax: option '%canonical_option%' is ambiguous</i> </b>


User 1577 | 3/18/2015, 12:43:05 PM

Danny, Thx again for the support. i managed to make it work. it seems i mixed between 2 different examples. All good now!