Fix: Unable to install GraphLab Create on Mac OX with Xcode version 5.1

User 9 | 3/20/2014, 7:26:30 PM

<b>Issue: </b> When using the following command to install GraphLab Create, installation will fail. <pre>$ pip install graphlab-create</br> ...

<pre>File "numpy/core/setup.py", line 674, in getmathlibinfo

raise RuntimeError("Broken toolchain: cannot link a simple C program")

RuntimeError: Broken toolchain: cannot link a simple C program


Cleaning up... Command python setup.py egg_info failed with error code 1 in /Users/timmuss/test/build/numpy Storing debug log for failure in /var/folders/2w/sxq274ts2v32g66fqkhf3tb40000gn/T/tmpJzaou1</pre>

<b>Cause:</b> GraphLab Create 0.1.0 installs <a href ="http://www.numpy.org/">numpy </a>, <a href="https://code.google.com/p/psutil/">psutil </a>and <a href="http://pandas.pydata.org/">pandas</a> as dependent Python packages. These packages error during install because of changes in the compiler of Xcode 5.1 resulting in a failed installation of GraphLab Create. <a href="https://developer.apple.com/library/ios/releasenotes/DeveloperTools/RN-Xcode/Introduction/Introduction.html>See Apple Xcode 5.1 release notes.</a>

<b>Fix: </b> pip install GraphLab Create using the following command (sudo may be required depending on how you choose to install)

<pre>$ ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future pip install graphlab-create</pre>

Please let us know if you have any further issues.

Comments

User 238 | 4/21/2014, 8:00:47 AM

Hi, I can still not get pass the error : "Command python setup.py egg_info failed with error code 1 in /Users/sjacobs/graphlab/build/numpy" while trying to install GraphLab Create even after trying your suggestion posted above. I have tried both system-wide installation and installation in virtual environment. I have also tried other suggestions like the one posted here - http://stackoverflow.com/questions/17886647/cant-install-via-pip-because-of-egg-info-error. My version of MacOSX is 10.9.2 and XCode is 5.1.1 Please find the log files for both system-wide install and virtual-env install attached. Thanks,


User 4 | 4/21/2014, 8:41:59 PM

@sjacobs‌ Based on the logs it looks like the ARCHFLAGS environment variable is not being passed through to clang (via pip). If you are running with sudo, try:

<pre>sudo ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future pip install graphlab-create</pre>

If you are not running with sudo then I would expect the following command to work:

<pre>ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future pip install graphlab-create</pre>


User 238 | 5/1/2014, 3:29:34 PM

@Zach, thanks a lot, it works! Also, the same command will fix similar problem for pip install matplotlib.