ImportError: cannot import name SFrame

User 164 | 3/20/2014, 6:15:46 AM

When I am trying to "import graphlab", ImportError occurs, showing the following details, >>> import graphlab Traceback (most recent call last): File "<stdin>", line 1, in <module> File "graphlab.py", line 2, in <module> from graphlab import SFrame ImportError: cannot import name SFrame

Anybody tell me what is the problem?

Comments

User 20 | 3/20/2014, 4:35:21 PM

Hi,

Can you provide some more details about your system? - What is the operating system (and version) you are running? - Are you using ipython? - Are you using a virtualenv? If you are: - What is the version of python, activate the virtualenv and run python --version If you are not: - Can you try using a virtualenv?

Thanks, Yucheng


User 164 | 3/21/2014, 9:30:01 AM

Thanks for the reply. I am using OS: ubuntu 13.04 in x86_64 I have tried ipython, default python, and virtualenv, all of them suffer the same problem by throwing the same exception. My python version is 2.7.6 Still not clear where is the problem.


User 20 | 3/21/2014, 5:17:49 PM

Hi,

I am not entirely sure what the problem is. I am suspecting an incomplete install or something like that. Can you do a pip uninstall graphlab-create, then from inside a virtualenv do a pip install graphlab-create.

Yucheng


User 4 | 3/21/2014, 5:20:20 PM

@codejedi‌, do you have a file in your project named 'graphlab.py'? The reason I ask is that graphlab-create does not ship with a file named graphlab.py, but the error message refers to such a file. I suspect that the problem might be that in another file, you 'import graphlab', then in graphlab.py, you import SFrame from graphlab. However, Python is finding your 'graphlab.py' as the 'graphlab' to import from, instead of the namespace from graphlab-create.


User 4 | 3/21/2014, 5:24:09 PM

If that is the case, you should be able to work around this error by renaming your graphlab.py to something else (like graphlabtest.py) and then importing it as "graphlabtest".


User 164 | 3/21/2014, 5:49:44 PM

Many thanks @Zach‌ . I was exactly encounter this problem. Just can't believe I made such mistakes. Also thanks all the same @Yucheng‌ .


User 4 | 3/21/2014, 6:20:20 PM

@codejedi‌ No problem, I'm glad I could help. I have run into similar problems before with other modules.


User 320 | 5/23/2014, 11:05:11 AM

Hi Guys

I have a similar problem after a successful install, I'm using Ubuntu 12.04 with Python 2.7 enthought distribution this is what I see

$ sudo pip install graphlab-create mutiple requirements satisfied until this last one Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in /usr/lib/python2.7/dist-packages (from pandas==0.13.1->graphlab-create) Cleaning up...

and then : $ ipython Enthought Python Distribution -- www.enthought.com

Python 2.7.3 |EPD 7.3-2 (64-bit)| (default, Apr 11 2012, 17:52:16) Type "copyright", "credits" or "license" for more information.

In [1]: import graphlab

ImportError Traceback (most recent call last) /home/german/<ipython-input-1-4b66ad388e97> in <module>() ----> 1 import graphlab

ImportError: No module named graphlab

Kind regards

German