Starting new HTTP connection on graphlab 1.3.0

User 1300 | 2/20/2015, 5:07:34 PM

Hi,

I'm testing graphlab 1.3.0. After almost every command related to gl, in ipython notebook (jupyter), I get this message multiple times (i removed the url): [INFO] Starting new HTTP connection (1): <someurlhere>.cloudfront.net [INFO] Starting new HTTP connection (1): <someurlhere>.cloudfront.net [INFO] Starting new HTTP connection (1): <someurlhere>.cloudfront.net [INFO] Starting new HTTP connection (1): <someurlhere>.cloudfront.net

An example code will be: <b class="Bold"><b class="Bold">import graphlab as gl</b></b>

Running that starts writing multiple lines of the message above. Later on, when creating a new SFrame or SArray also produces the same message multiple times. It seems it's trying to connect somewhere because the message repeats about every ~1 sec

Guy

Comments

User 92 | 2/20/2015, 7:06:59 PM

Hi Guy,

It seems that the requests module's logging level changed some how in your session. Can you try do the following and see if the logging information goes away?

import logging logging.getLogger("requests").setLevel(logging.WARNING)

Thanks! Ping


User 1300 | 2/25/2015, 1:43:11 PM

I still get this at some of the commands. For example, after creating a new SFrame or displaying the sf.head(10) the row appeared about 20 times times. The logging level is INFO

[INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net [INFO] Starting new HTTP connection (1): d3dr4ny6.cloudfront.net ...


User 92 | 2/25/2015, 7:28:51 PM

Does this still happen after you do:

	import logging
	logging.getLogger("requests").setLevel(logging.WARNING)

This should turn the logging level to WARNING, which is default logging level for request module.


User 1300 | 2/26/2015, 6:31:23 PM

Hi wangping,

I added it to the code.

import logging logging.getLogger("requests").setLevel(logging.WARNING)

yet I still get the this message. Btw, I'm using Jupyter as a notebook (If this is related).

Thanks, Guy


User 940 | 3/6/2015, 10:51:29 PM

Hi Guy,

Does the following work?

logging.disable(logging.INFO)

Cheers! -Piotr


User 949 | 6/13/2015, 12:57:13 PM

Just got this (again) in GLC 1.4, followed piotr's answer:

python import logging logging.disable(logging.INFO)

and it worked!!!

Thanks!


User 19 | 6/14/2015, 8:46:44 PM

Great to hear. Thanks for letting us know!