Communication failure 65

User 1129 | 2/16/2015, 9:11:17 AM

I have a code that worked. Suddenly it stopped working, reporting "Communication failure 65". The piece of code that causes the problem is <code>gl.loadsframe(mybinarySFramedirecory)</code>. It is important to note that the code worked. I changed neither the code nor the data.

Also, I have upgraded to 1.3.0, but still no effect.

Following is the exception trace (after minor obfuscation)

<code> <ipython-input-5-65a8225b6335> in <module>() ----> 1 ga = MyClass.loadfromdirectory(da).graph 2 gm = MyClass.loadfromdirectory(dm).graph 3 gz = MyClass.loadfromdirectory(dz).graph

/path/to/project/src/myclass.pyc in loadfromdirectory(cls, dirname)

--> 419 tbl = gl.loadsframe(os.path.join(dirname, 'tbl'))

/usr/local/lib/python2.7/site-packages/graphlab/datastructures/sframe.pyc in loadsframe(filename) 228 >>> sfloaded = graphlab.loadsframe('my_sframe') 229 """ --> 230 sf = SFrame(data=filename) 231 return sf 232

/usr/local/lib/python2.7/site-packages/graphlab/datastructures/sframe.pyc in init(self, data, format, proxy) 774 self.proxy = proxy 775 else: --> 776 self.proxy = UnitySFrameProxy(glconnect.getclient()) 777 _format = None 778 if (format == 'auto'):

/usr/local/lib/python2.7/site-packages/graphlab/cython/cysframe.so in graphlab.cython.cysframe.UnitySFrameProxy.cinit()

RuntimeError: Communication Failure: 65. </code>

Comments

User 1129 | 2/16/2015, 9:45:25 AM

This is strange. This bug occurs when and only when the code contains the following import statement

<code>import ggplot as gg</code>

Here, ggplot is the excellent plotting library http://ggplot.yhathq.com/ . It looks like there is a name conflict, since if I do <code>import ggplot</code>

or

<code>import ggplot as anythingbutgg</code>

..., then everything works normally.

Well, at least I can work again. Good luck with that bug :-)


User 954 | 2/16/2015, 6:51:36 PM

Hi, thanks for reporting the bug. Could you provide us with a minimal set of code that cause the problem in 1.3. I am not able to regenerate the problem.


User 1132 | 2/17/2015, 8:11:18 PM

I wanted to add that I also came across this error when trying to train and access multiple topic_models inside an ipython notebook using the autoreload extension.


User 1129 | 2/18/2015, 3:57:28 PM

Today I couldn't reproduce this error. Strange.


User 1132 | 2/19/2015, 4:21:49 AM

No worries, If I find it happening again, I'll see if I can wrap up the code for you to test it.


User 1132 | 2/24/2015, 11:45:15 PM

This error seems to occur anytime the GL server crashes, here's code that causes this to happen.

<pre class="CodeBlock"><code>import graphlab as gl docs = gl.SArray('http://s3.amazonaws.com/dato-datasets/nips-text') m1 = gl.topicmodel.create(docs, numtopics=30, numiterations=50, verbose=False, printinterval=0)</code></pre>

Here the <code>print_interval=0</code> is what seems to crash the server. My earlier comment seemed to have a crashing server due to some other issue. I've looked in the graphlab logs created in my /tmp directory, though there's no output related to the server crashing. Is there any easier way we can debug this type of error?


User 954 | 2/25/2015, 7:49:43 PM

Hi Paul,

Thanks for reporting the bug. Print_interval should be always greater than zero. This issue will be fixed in the next release. Currently the only way to get more information about the error at the user-side is by looking at log files, which is not very helpful in certain scenarios. We are considering other alternatives.


User 1132 | 2/25/2015, 7:53:42 PM

Thanks for the update. As an aside, It would be nice to be able to silence all output of the topic model training in some cases. Some of the other gl-create models allow this when verbose is False.


User 1314 | 3/3/2015, 12:52:36 AM

Hello folks, I run into this error quite a bit, too. After training a recommender in ipython notebook, calling evaluate() or compareModels() on models will throw this error.

http://nbviewer.ipython.org/gist/jinsu/d31075fb4ccf2972447a

I run into this about 70% of the time and I have no reliable way to fix it other than delete /tmp/graphlab_server* and repeat until it works...

Adding that I'm on Graphlab Create 1.3

Any ideas why this error occurs to me so many times?


User 1314 | 3/3/2015, 2:34:01 AM

Sure i will email, brian. Thanks for taking a look at it.