Cannot fetch index base URL http://pypi.python.org/simple/

User 9 | 3/20/2014, 3:06:59 AM

This was a prior post by mrex. Thanks for the feedback! (moving to separate thread)

Hi,

I followed the instruction to install graphlab-create on my Ubuntu machine (Intel core i7-3517U CPU @ 1.90GHz) but pip install graphlab-create fails. The error is reproduced by:

pip install pandas==0.13.1

error: Cannot fetch index base URL http://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement pandas==0.13.1 No distributions at all found for pandas==0.13.1

Following the suggestions available at : http://forum.graphlab.com/discussion/55/graphlab-create-0-1-0-beta-linux-installation-notes

I verified the availability of the build-essential package on my system:

sudo apt-get install build-essential

but apt-get says that build-essential is already the newest version. Not sure what to do to solve. Any help would be greatly appreciated. Thanks in advance.

Matteo

Comments

User 9 | 3/20/2014, 3:08:10 AM

Here is the reply by JayGu.

Hi Matteo,

Looks like it cannot connect get the package index from pypi. Maybe the network was bad at the time you tried to install or the pypi server was down. I just tried "pip install pandas===0.13.1" and had not problem with that. Would you mind try again, and tell us if it works now?

Thanks, -jay


User 9 | 3/20/2014, 3:09:19 AM

Hi mrex, are you still having this issue? We will investigate further if you are stuck.


User 217 | 4/10/2014, 4:46:05 PM

i have the same problem. i am trying to install lxml using this command: "pip install lxml" the output is: "Downloading/unpacking lxml Cannot fetch index base URL http://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement lxml No distributions at all found for lxml Storing complete log in ....\pip\pip.log" what could be the problem!!?

Thanks, Shady