Cannot use graphlab from a different user

User 1193 | 1/13/2015, 10:35:43 AM

Hi, We installed graphlab on our linux machine (centos 6) using the root user. We have 2 users (but root)- one of them can use graphlab but the other can't. We got the following error: - [ERROR] Fatal error. The unity_server process cannot be started. There may have been an issue during installation of graphlab-create. Please uninstall graphlab-create and reinstall it, looking for errors that may occur during installation. If the problem persists, please contact support@graphlab.com.

I tried few things so far- nothig worked: 1. Created a new key for the problematic user 2. Copy the entire .graphlab directory from the working user to the other one 3. Created a symbolic link from the problematic user to the .graphlab directory of the working user.

Comments

User 1195 | 1/13/2015, 4:45:51 PM

Hi Michal,

On Ubuntu 14.04.1, I just created a new user, copied the .graphlab folder to the new user's home folder (and changed the permissions so the new user would own it), and imported GraphLab (and created an SGraph() instance, which fires up the Unity server) just fine. So my recommendation is, switch to Ubuntu :smile: or just try to describe your problem in more detail:

  1. How soon do you get this error message? When you first try to create an SFrame or SGraph? Earlier than that?
  2. GraphLab stores log file under /tmp - can you please look them up and see if you can come up with anything interesting? Post it here or send it to me these logs to guy@graphlab.com .
  3. Are the same LDLIBRARYPATH and PYTHONPATH environment variables are defined for both of these users?

User 1189 | 1/13/2015, 4:50:20 PM

Interesting. I will investigate and try to reproduce. It is likely a permissions issue.

In the meantime this is my immediate hypothesis:

If you cd into the graphlab-create installation location,

You can get it with:

import graphlab
graphlab.__file__

It should print something like

/usr/local/lib/python2.7/site-packages/graphlab/__init__.py

cd into the path (ex: /usr/local/lib/python2.7/site-packages/graphlab)

There should be a collection of executables in the directory like:

unity_server
pylambda_worker
rddtosf_nonpickle
rddtosf_pickle
sftordd_pickle

Make sure there is executable permissions on all of those:

sudo chmod o+x unity_server
sudo chmod o+x pylambda_server

etc.

In the meantime I will try to reproduce and verify the above workaround or come up with a new one.

Thanks, Yucheng


User 1189 | 1/13/2015, 4:53:10 PM

Ah. I appeared to have posted at about the same time as Guy who has actually tried it out and seems to work fine for him.

Can I have more information regarding the system? (uname -a) Also, are both users running the same Python? (system-wide installation of Python)


User 1193 | 1/14/2015, 9:05:14 AM

Thanks a lot! It's working now- the LDLIBRARYPATH env var wasn't defined.