AttributeError: 'module' object has no attribute 'SFrame'

User 1145 | 1/2/2015, 6:50:34 AM

Using Anaconda, Spyder 2, when I run:

import graphlab as gl bookreviews = gl.SFrame('sframes/bookreviews/')'

it gives me the error: AttributeError: 'module' object has no attribute 'SFrame'

How do I fix this?

Comments

User 303 | 4/2/2015, 6:30:01 PM

I have installed graphlab in ubuntu 12.04, as mentioned in https://dato.com/products/create/quick-start-guide.html When I try helloworld.py , I get AttributeError: 'module' object has no attribute 'SFrame'


User 9 | 5/12/2015, 5:26:57 AM

@"Swaroop Krothapalli"

Are you able to execute this code without error? import graphlab graphlab.SFrame()


User 3510 | 3/12/2016, 5:57:26 PM

Hi Timmuss, I received the same error above on my Macbook Pro running OSX (latest edition). I copied your code directly into my iPython notebook, and it worked just fine. Please take a look at the photo. After copying your code, and loading my gl dataframe, I run the exact same code, except I type it in, and I receive the Attribute Error. Any idea what could be causing this problem?


User 3510 | 3/12/2016, 6:05:00 PM

Hi Again: Sorry about the double comment. I have managed to solve the problem entirely by simply shutting down ipython notebook, and reopening. But, still it was very weird. Any idea what could have caused the problem?


User 15 | 3/12/2016, 7:32:57 PM

@Cookdj0128 The 'f' must be capitalized in 'SFrame'.


User 3510 | 3/20/2016, 3:22:41 PM

Wow, I think I need to get my eyes checked. Thanks Evan!