ALS graphchi error

User 986 | 12/9/2014, 8:44:14 PM

I am working on matrix factorization project and I need to compare my results with alternating least square algorithm for matrix factorization, I downloaded the graphchi library and try to run the algorithm but it give me this result:

./toolkits/collaborativefiltering/als --training=ua.base --validation=ua.test --lambda=0.065 --minval=1 --maxval=5 --maxiter=6 --quiet=1 WARNING: common.hpp(print_copyright:214): GraphChi Collaborative filtering library is written by Danny Bickson (c). Send any comments or bug reports to danny.bickson@gmail.com [training] => [ua.base] [validation] => [ua.test] [lambda] => [0.065] [minval] => [1] [maxval] => [5] [max_iter] => [6] [quiet] => [1] Segmentation fault (core dumped)

I am trying the command with smallnetflixmm and smallnetflixmme but it give me the same error :( I apply the commands in bickson.blogspot.com/2012/12/collaborative-filtering-with-graphchi.html

I hope you can help me,

Comments

User 6 | 12/10/2014, 5:59:25 AM

I already answered your question on nov 26.

We highly recommend switching to GraphLab Create, as it will be easier for us to give support, and we have much newer functionality there.

Regarding GraphChi, <b class="Bold">please verify you are using a 64 bit machine. You should compile in debug mode (using "make clean; make cfd"), run again and send us the error you are getting. </b>

Without further information we are not able to debug.


User 986 | 12/10/2014, 10:26:54 AM

Thanks alot danny for your suggestion, This is what I get it when I use gdb

Starting program: /home/nourah/Desktop/graphchiv0.2.6/graphchi/toolkits/collaborativefiltering/als --training=smallnetflixmm--validation=smallnetflixmme--lambda=0.065--minval=1--maxval=5--max_iter=6--quiet=1 [Thread debugging using libthreaddb enabled] Using host libthreaddb library "/lib/i386-linux-gnu/libthreaddb.so.1". WARNING: common.hpp(printcopyright:183): GraphChi Collaborative filtering library is written by Danny Bickson (c). Send any comments or bug reports to danny.bickson@gmail.com [training] => [smallnetflixmm--validation=smallnetflixmme--lambda=0.065--minval=1--maxval=5--maxiter=6--quiet=1] INFO: sharder.hpp(startpreprocessing:207): Started preprocessing: smallnetflixmm--validation=smallnetflixmme--lambda=0.065--minval=1--maxval=5--maxiter=6--quiet=1 --> smallnetflixmm--validation=smallnetflixmme--lambda=0.065--minval=1--maxval=5--maxiter=6--quiet=1.4B.bin.tmp FATAL: io.hpp(detectmatrixsize:88): Failed to open input file: smallnetflixmm--validation=smallnetflixmme--lambda=0.065--minval=1--maxval=5--max_iter=6--quiet=1 terminate called after throwing an instance of 'char const*'

Program received signal SIGABRT, Aborted. 0xb7fdd424 in __kernel_vsyscall () (gdb)


User 986 | 12/10/2014, 2:10:17 PM

When I changed the dataset and run it again I got this results

(gdb) run --training=smallnetflixmm --validation=smallnetflixmme --lambda=0.065 --minval=1 -- maxval=5 --maxiter=12 --quiet=1 Starting program: /home/nourah/Desktop/graphchiv0.2.6/graphchi/toolkits/collaborativefiltering/als --training=smallnetflixmm --validation=smallnetflixmme --lambda=0.065 --minval=1 -- maxval=5 --maxiter=12 --quiet=1 [Thread debugging using libthreaddb enabled] Using host libthreaddb library "/lib/i386-linux-gnu/libthreaddb.so.1". WARNING: common.hpp(printcopyright:183): GraphChi Collaborative filtering library is written by Danny Bickson (c). Send any comments or bug reports to danny.bickson@gmail.com [training] => [smallnetflix_mm] [validation] => [smallnetflix_mme] [lambda] => [0.065] [minval] => [1] [max_iter] => [12] [quiet] => [1]

Program received signal SIGSEGV, Segmentation fault. 0xb7f096f9 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6


User 6 | 12/10/2014, 3:04:01 PM

It looks like you did not compile in debug mode. Please do in the root graphchi folder "make clean; make cfd" and send me again the output


User 986 | 12/10/2014, 5:09:40 PM

Thank you danny but I used make clean -> make cfd -> gdb ./toolkits/collaborativefiltering/als ->
(gdb) run --training=smallnetflix
mm --validation=smallnetflixmme --lambda=0.065 --minval=1 -- maxval=5 --maxiter=12 --quiet=1

it gave me the same error


User 6 | 12/12/2014, 6:23:05 AM

Now run with --quiet=0 and send me the full output again. Is this a virtual machine? are you sure this is a 64 bit machine?


User 986 | 12/13/2014, 6:51:05 PM

Yes, it is 64 bit machine This what I get

(gdb) run --training=smallnetflixmm --validation=smallnetflixmme --lambda=0.065 --minval=1 -- maxval=5 --maxiter=12 --quiet=0 Starting program: /home/nourah/graphchi/toolkits/collaborativefiltering/als --training=smallnetflixmm --validation=smallnetflixmme --lambda=0.065 --minval=1 -- maxval=5 --max_iter=12 --quiet=0 [Thread debugging using libthreaddb enabled] Using host libthreaddb library "/lib/i386-linux-gnu/libthreaddb.so.1". WARNING: common.hpp(printcopyright:183): GraphChi Collaborative filtering library is written by Danny Bickson (c). Send any comments or bug reports to danny.bickson@gmail.com [training] => [smallnetflix_mm] [validation] => [smallnetflixmme] [lambda] => [0.065] [minval] => [1] [max_iter] => [12] [quiet] => [0] INFO: sharder.hpp(startpreprocessing:207): Started preprocessing: smallnetflixmm --> smallnetflixmm.4B.bin.tmp

Program received signal SIGSEGV, Segmentation fault. 0xb7f096f9 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6


User 6 | 12/14/2014, 6:15:39 AM

Hi, There is simply not enough information for debugging your error. I suggest switching to GraphLab Create were we recently added ALS version. It will be much easier for us to help you debug our newer platform.


User 986 | 12/15/2014, 3:53:06 PM

Ok, I will do Thank you very much Danny