Build my_first_app on Mac OSX 10.10 Yosemite

User 956 | 11/23/2014, 2:31:08 PM

Hello,

I try to make the "myfirstapp", but zookeeper seems to be a problem.

I am running on Mac OSX 10.10, 64 bit, 8gb

I guess this (<a href="https://issues.apache.org/jira/browse/ZOOKEEPER-2049">Zookeeper Patch</a>) is the solution, but I don't know how to apply this patch. I tried to copy the patch file into the patches folder, but this doesn't change anything.

Attached is the output of the shell. I am new to GraphLab, I hope you can help me.

Regards, Tarek

Comments

User 6 | 11/24/2014, 4:02:10 PM

Hi Tarek, This version of powergraph is going to be deprecated soon. We highly recommend switching to GraphLab Create where it will be much easier for us to support you.

It seems that Mac 10.10 broke zookeeper. The quick workaround would be to switch to earlier MAC like 10.9 or even easier to Ubuntu.

If you insist on working with Mac 10.10 you will need to install zookeeper locally under local/deps/ on your own. I attach a list of the directory structure under GRAPHLAB_ROOT/local/deps/zookeeper. If you managed to install it, you will get the same set of files as listed below. If you have issues you may contact zookeeper support.


User 956 | 11/24/2014, 6:13:02 PM

OK thanks, I won't use it, if it's deprecated soon. Does GraphLab Create still have a C++ API or is the plan to stick to Python as interface? What is the best way to implement fast new graph algortihm?

Thanks for your help! Tarek


User 6 | 11/25/2014, 6:01:40 AM

Hi Tarek, GraphLab Create has Python API, while keeping the efficient c++ performance of older powergraph. I have answered your other forum question - we suggest starting here: http://graphlab.com/products/create/docs/generated/graphlab.SGraph.triple_apply.html when you like to implement a graph algorithm.


User 1768 | 4/22/2015, 4:42:12 PM

I have the problem with installing PowerGraph in Macbook and not possible to go to Graphlab Create now.

When I am running PowerGraph ./configure, it gives me error . "You stated that It seems that Mac 10.10 broke zookeeper. The quick work around would be to switch to earlier MAC like 10.9 or even easier to Ubuntu.", I have to install Xcode first and to install it I had to upgrade my mac 10.9 to 10.10. if I go to lower mac again, I will not be able to install Xcode.

I try to run PowegGraph in Virtual box, Ubuntu. But, it consider my PC as one core and give me error when I try to run myfirstapp. What I need to do? Please help.


User 4 | 4/22/2015, 7:50:58 PM

Hi @naoomi, if your host machine has multiple cores, you can try to enable multiple virtual cores for VirtualBox so it can run PowerGraph inside VirtualBox. Try the suggestions here: http://stackoverflow.com/questions/19590531/how-do-i-enable-multiple-cores-in-my-virtual-enviroment


User 1768 | 4/23/2015, 7:53:12 AM

Hi, wow @Zach you are angle man. Whatever I say thanks is not enough. It solved on both PC and Mac with Virtual box, Ubuntu. Best Wishes.


User 2603 | 11/15/2015, 9:22:16 AM

I still can not build zookeeper on mac