can't download gperftools-2.0.tar.gz

User 914 | 11/10/2014, 2:52:35 AM

Hi all!

When I tried to do make in any toolkits folders, the process always halted when downloading the file gperftools-2.0.tar.gz. It said I can't connect to server and had these print out:

-- downloading... src='http://gperftools.googlecode.com/files/gperftools-2.0.tar.gz' dst='/home/nxf17/graphlab/deps/tcmalloc/src/gperftools-2.0.tar.gz' timeout='none' CMake Error at libtcmalloc-stamp/download-libtcmalloc.cmake:21 (message): error: downloading 'http://gperftools.googlecode.com/files/gperftools-2.0.tar.gz' failed

status_code: 7
status_string: "couldn't connect to server"
log: About to connect() to gperftools.googlecode.com port 80 (#0)
Trying 74.125.31.82... Connection timed out

couldn't connect to host

Closing connection #0

couldn't connect to server

And I tried to download the file myself and place it in the folder /graphlab/deps/tcmalloc/src/ , but it just start re-downloading it when I make again. How can I solve this? I really need some help... Thanks a lot!

Comments

User 6 | 11/10/2014, 4:57:56 AM

It sounds like the host for this file is down. You can try to configure without tcmalloc using the command ./configure --no_tcmalloc In the root graphlab folder, and then compile again.


User 914 | 11/11/2014, 9:54:09 AM

Thanks, it helps!


User 6 | 11/11/2014, 10:39:57 AM

Glad to hear it works. Please note that once you disable tomalloc most likely you will have degraded performance when running with multicores, it is recommended to try again when their server is up (maybe you need to configure proxy server in your network to be able to download this external library).