Compiling GraphLab: Permission denied

User 90 | 11/3/2014, 6:33:42 AM

I am trying to compile the graph analytics toolkit from GraphLab on our cluster, but am unable to do so. On running <code class="CodeInline">make -j4</code> in <code class="CodeInline">release/toolkits/graph_analytics</code>, I get the following error:

<pre class="CodeBlock"><code>-- [download 100% complete] -- downloading... done -- verifying file... file='/home/kvora001/workspace/graphlab/new-version/graphlab-master/deps/hadoop/src/hadoop-1.0.1.tar.gz' -- verifying file... done -- extracting... src='/home/kvora001/workspace/graphlab/new-version/graphlab-master/deps/hadoop/src/hadoop-1.0.1.tar.gz' dst='/home/kvora001/workspace/graphlab/new-version/graphlab-master/deps/hadoop/src/hadoop' -- extracting... [tar xfz] -- extracting... [analysis] -- extracting... [rename] -- extracting... [clean up] -- extracting... done [ 42%] [ 44%] Performing patch step for 'hadoop' Performing update step for 'hadoop' patching file src/c++/libhdfs/hdfsJniHelper.c patching file src/c++/libhdfs/configure patching file src/c++/libhdfs/configure.ac patching file src/c++/libhdfs/hdfs.c Hunk #1 succeeded at 252 with fuzz 2. [ 46%] Performing configure step for 'hadoop' /bin/sh: /home/kvora001/workspace/graphlab/new-version/graphlab-master/deps/hadoop/src/hadoop/src/c++/libhdfs/configure: Permission denied make[2]: * [../deps/hadoop/src/hadoop-stamp/hadoop-configure] Error 126 make[1]: [CMakeFiles/hadoop.dir/all] Error 2 make: ** [all] Error 2</code></pre>

It seems the issue is related to permissions needed for installation -- unfortunately I do not own the cluster and cannot compile GraphLab with higher permissions. Please let me know how I can install GraphLab.

Comments

User 6 | 11/3/2014, 6:42:33 AM

Hi, This is a known issue simply run the command chmod a+rx /home/kvora001/workspace/graphlab/new-version/graphlab-master/deps/hadoop/src/hadoop/src/c++/libhdfs/configure and this issue will be fixed.

Please note that you are using our older code, we have a new graph analytics library as part of GraphLab Create. See here: http://graphlab.com/products/create/docs/graphlab.toolkits.graph_analytics.html


User 90 | 11/3/2014, 7:10:49 AM

Thanks Danny! Changing the permission solved the issue.

Also, I will look into using GraphLab Create for updated graph analytics library.