"RuntimeError: Communication Failure: 65." with sklearn.

User 869 | 10/20/2014, 3:10:21 AM

There is a problem in grphlab work with imported sklearn. Here is my code:

<pre class="CodeBlock"><code>import graphlab data = graphlab.SFrame({'item':[1,2,3],'user':[5,6,7],'rating':[8,9,0]}) print data

from sklearn.metrics import precisionrecallcurve data = graphlab.SFrame({'item':[1,2,3],'user':[5,6,7],'rating':[8,9,0]}) print data</code></pre>

And here is an output:

<blockquote class="Quote">[INFO] Start server at: ipc:///tmp/graphlabserver-42913 - Server binary: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/graphlab/unityserver - Server log: /tmp/graphlabserver1413774162.log [INFO] GraphLab Server Version: 1.0 +------+--------+------+ | item | rating | user | +------+--------+------+ | 1 | 8 | 5 | | 2 | 9 | 6 | | 3 | 0 | 7 | +------+--------+------+ [3 rows x 3 columns]

Unable to reach server for 3 consecutive pings. Server is considered dead. Please exit and restart. Traceback (most recent call last): File "/Users/konstantinbauman/workspace/packages/code/graphlab/firsttry.py", line 10, in <module> data = graphlab.SFrame({'item':[1,2,3],'user':[5,6,7],'rating':[8,9,0]}) File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/graphlab/datastructures/sframe.py", line 342, in init self.proxy = UnitySFrameProxy(glconnect.getclient()) File "cysframe.pyx", line 58, in graphlab.cython.cy_sframe.UnitySFrameProxy.cinit RuntimeError: Communication Failure: 65. [INFO] Stopping the server connection. Unable to reach server for 4 consecutive pings. Server is considered dead. Please exit and restart. [WARNING] <type 'exceptions.IOError'> [WARNING] <type 'exceptions.ValueError'> [INFO] GraphLab server shutdown</blockquote>

Comments

User 19 | 10/20/2014, 3:27:10 AM

Hi Konstantin,

I have not yet been able to reproduce this error; your code snippet works for me.

Can you let us know how you installed GraphLab Create? Would you mind trying to <a href="http://graphlab.com/products/create/quick-start-guide.html#install-with-virtualenv">use virtualenv</a> and see if that helps?

Thanks, Chris