Make file error

User 770 | 9/26/2014, 9:26:02 AM

Hi all,

I tried following the installation guide on http://graphlab.org/projects/getting_started.html and all steps works fine. However I'm stuck in the step of "make -j4", I encounter the following error. Could someone help me with that? Thanks a lot.

In file included from ./boost/config.hpp:57:0, from ./boost/programoptions/config.hpp:10, from ./boost/programoptions/parsers.hpp:10, from libs/programoptions/src/split.cpp:8: ./boost/lexicalcast.hpp: In function ‘CharT* boost::detail::lcastputunsigned(T, CharT*)’: ./boost/staticassert.hpp:125:21: warning: typedef ‘booststaticasserttypedef787’ locally defined but not used [-Wunused-local-typedefs] BOOSTJOIN(booststaticasserttypedef, LINE) ^ ./boost/lexicalcast.hpp:787:13: note: in expansion of macro ‘BOOSTSTATICASSERT’ BOOSTSTATICASSERT(!std::numericlimits<T>::issigned); ^ ./boost/staticassert.hpp:125:21: warning: typedef ‘booststaticasserttypedef812’ locally defined but not used [-Wunused-local-typedefs] BOOSTJOIN(booststaticasserttypedef, LINE) ^ ./boost/lexicalcast.hpp:812:17: note: in expansion of macro ‘BOOSTSTATICASSERT’ BOOSTSTATICASSERT(std::numericlimits<T>::digits10 < CHARMAX); ^ ./boost/lexicalcast.hpp: In function ‘bool boost::detail::lcastret_unsigned(T&, const CharT, const CharT)’: ./boost/staticassert.hpp:125:21: warning: typedef ‘booststaticasserttypedef866’ locally defined but not used [-Wunused-local-typedefs] BOOSTJOIN(booststaticasserttypedef, LINE) ^ ./boost/lexicalcast.hpp:866:13: note: in expansion of macro ‘BOOSTSTATICASSERT’ BOOSTSTATICASSERT(!std::numericlimits<T>::issigned); ^ In file included from ./boost/programoptions/valuesemantic.hpp:14:0, from ./boost/programoptions/optionsdescription.hpp:13, from ./boost/programoptions/detail/cmdline.hpp:14, from ./boost/programoptions/parsers.hpp:12, from libs/programoptions/src/split.cpp:8: ./boost/lexicalcast.hpp:868:47: warning: typedef ‘inttype’ locally defined but not used [-Wunused-local-typedefs] typedef typename Traits::inttype inttype; ^ In file included from ./boost/config.hpp:57:0, from ./boost/programoptions/config.hpp:10, from ./boost/programoptions/parsers.hpp:10, from libs/programoptions/src/split.cpp:8: ./boost/lexicalcast.hpp: In member function ‘bool boost::detail::lexicalstreamlimitedsrc<CharT, Traits, RequiresStringbuffer>::shlchar(T)’: ./boost/staticassert.hpp:125:21: warning: typedef ‘booststaticasserttypedef1469’ locally defined but not used [-Wunused-local-typedefs] BOOSTJOIN(booststaticasserttypedef, LINE) ^ ./boost/staticassert.hpp:23:45: note: in expansion of macro ‘BOOSTSTATICASSERT’ # define BOOSTSTATICASSERTMSG( B, Msg ) BOOSTSTATICASSERT( B ) ^ ./boost/lexicalcast.hpp:1467:17: note: in expansion of macro ‘BOOSTSTATICASSERTMSG’ BOOSTSTATICASSERTMSG(( sizeof(T) <= sizeof(CharT)) , ^ ./boost/lexicalcast.hpp: In member function ‘bool boost::detail::lexicalstreamlimitedsrc<CharT, Traits, RequiresStringbuffer>::shlchararray(const T*)’: ./boost/staticassert.hpp:125:21: warning: typedef ‘booststaticasserttypedef1494’ locally defined but not used [-Wunused-local-typedefs] BOOSTJOIN(booststaticasserttypedef, LINE) ^ ./boost/staticassert.hpp:23:45: note: in Html�I�M! ��7# ++����FYI: If you are using Anaconda and having problems with NumPyHello everyone,

I ran into an issue a few days ago and found out something that may be affecting many GraphLab users who use it with Anaconda on Windows. NumPy was unable to load, and consequently everything that requires it (Matplotlib etc).

It turns out that the current NumPy build (1.10.4) for Windows is problematic (more info here).

Possible workarounds are downgrading to build 1.10.1 or forcing an upgrade to 1.11.0 if your dependencies allow. Downgrading was easy for me using conda install numpy=1.10.1

Thanks for your attention!

RafaelMarkdown558,824,8414L���4L���179.110.206.156179.110.206.1564P�}��Xj�8\j�1str�"��\j�Xj��\j�8bj�րi�1(׀i��g��b�j����Xj�\j�Xj�8\j�1.hpp(decrementdistributedcounter:787): Distributed Aggregation of likelihood. 0 remaining. INFO: distributedaggregator.hpp(decrementdistributedcounter:793): Aggregate completion of likelihood Likelihood: -3.22336e+08 INFO: distributedaggregator.3HLABDISABLELAMBDA_SHM"] = "1" os.environ["GRAPHLABFORCEIPCTOTCP_FALLBACK"] = "1" import graphlab as gl

3. Test out your lambda worker code in this environment. If it works, then you can make the above configuration permanent by running:

gl.sys_util.write_config_file_value("GRAPHLAB_DISABLE_LAMBDA_SHM", "1")
gl.sys_util.write_config_file_value("GRAPHLAB_FORCE_IPC_TO_TCP_FALLBACK", "1")

Note that this can be undone by setting these to "0" instead of "1", or by editing the file given by gl.sys_util.get_config_file().

4. If the lambda workers do not work after trying step 1, then there are two things we would very much appreciate you do to help us track down the issue.

4.1. First, execute the following code in a clean python shell, where you have not yet imported graphlab create. At the end of this code, it prints out the path to a zip file that, if you could send it to us, will help us diagnose the issue. Please create a support tick^j�8bj�2�"��bj�^j��bj�8�j�րi�2(׀i����^j�8bj�2

Comments

User 4 | 9/27/2014, 4:32:01 PM

Hi @kksin, in the log attached I do not see any errors (just some warnings), although there is an error reported at the end. Could you try re-running with just "make" (without -j4), which will remove parallelism, then paste the log here? Sometimes the log from a parallel (-j) make gets out of order and it becomes difficult to find errors.


User 770 | 9/29/2014, 2:40:05 AM

Hi @Zach, thanks for the reply. Please find as follows the log after re-running with just "make"

[ 5%] Built target zookeeper [ 9%] Built target libbz2 [ 10%] Performing build step for 'boost' Performing configuration checks

- 32-bit                   : no
- 64-bit                   : yes
- x86                      : yes

Component configuration:

- atomic                   : not building
- chrono                   : not building
- context                  : building
- date_time                : building
- exception                : not building
- filesystem               : building
- graph                    : not building
- graph_parallel           : not building
- iostreams                : building
- locale                   : not building
- math                     : not building
- mpi                      : not building
- program_options          : building
- python                   : not building
- random                   : building
- regex                    : not building
- serialization            : not building
- signals                  : not building
- system                   : building
- test                     : not building
- thread                   : not building
- timer                    : not building
- wave                     : not building

...patience... ...found 20411 targets... ...updating 4 targets... gcc.compile.c++ bin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi/zlib.o libs/iostreams/src/zlib.cpp:20:76: fatal error: zlib.h: No such file or directory #include "zlib.h" // Jean-loup Gailly's and Mark Adler's "zlib.h" header. ^ compilation terminated.

"g++"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -pthread  -DBOOST_ALL_NO_LIB=1 -DBOOST_IOSTREAMS_USE_DEPRECATED -DNDEBUG  -I"." -c -o "bin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi/zlib.o" "libs/iostreams/src/zlib.cpp"

...failed gcc.compile.c++ bin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi/zlib.o... ...skipped <pbin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi>libboostiostreams.a(clean) for lack of <pbin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi>zlib.o... ...skipped <pbin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi>libboostiostreams.a for lack of <pbin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi>zlib.o... ...skipped <p/opt/graphlab/deps/local/lib>libboostiostreams.a for lack of <pbin.v2/libs/iostreams/build/gcc-4.8.2/release/link-static/runtime-link-static/threading-multi>libboostiostreams.a... ...failed updating 1 target... ...skipped 3 targets... make[2]: * [../deps/boost/src/boost-stamp/boost-build] Error 1 make[1]: [CMakeFiles/boost.dir/all] Error 2 make: ** [all] Error 2


User 6 | 9/29/2014, 3:46:01 AM

Hi, It seems zlib is missing on your system. You will need to install it - this dependency is listed on our getting started page: "zlib [Required] Comes with most Mac/Linux systems by default. Recent Ubuntu version will require the zlib1g-dev package." If you are using Ubuntu you can easily installed it by the command "sudo apt-get install zlib1g-dev"