It seems I'm not able to load data in to toolbox algorithms, somewhat cumbersome...

User 94 | 3/6/2014, 8:32:37 AM

I'm following this example: http://docs.graphlab.org/collaborative_filtering.html#SVD And I get these results:

alex@Jobb:~/Dokument/Exjobb/graphlab-master/release/toolkits/collaborativefiltering$ ./svd A2 --rows=3 --cols=4 --nsv=3 --nv=4 --maxiter=3 --quiet=1 --save_vectors=1 --predictions=out Loading graph. Loading graph. Finished in 0.008053 Finalizing graph. Finalizing graph. Finished in 3.4e-05 ========== Graph statistics on proc 0 =============== Num vertices: 0 Num edges: 0 Num replica: 0 Replica to vertex ratio: -nan


Num local own vertices: 0 Num local vertices: 0 Replica to own ratio: -nan Num local edges: 0 Edge balance ratio: -nan Creating engine Running SVD (gklanczos) (C) Code by Danny Bickson, CMU Please send bug reports to danny.bickson@gmail.com FATAL: svd.cpp(init_lanczos:316): Failed to load graph. Aborting Aborted (core dumped)

Any advice is appreciated!

PS. the same thing probably happens when I run svd and svdpp on "smallnetflix" as I, unfortunately, get segfault after loading graphs. My thoughts is indexing an empty array -> segfault... DS.

Comments

User 6 | 3/6/2014, 9:15:31 AM

Hi, Did you create a folder named A2 and inside it a file named A2? It seems GraphLab does not find the input file and thus the graph has zero edges and zero nodes.


User 6 | 3/6/2014, 1:33:46 PM

Hi Alex, I have doubled checked on our side and the example works perfectly with the latest graphlab. It seems that your A2 file is empty or the folder A2 is empty. To make the error message clearer I have checked into github a sanity check that fails if the graph size is zero. Now you will get the error:

./svd A2 --rows=3 --cols=4 --nsv=3 --nv=4 --maxiter=3 --quiet=1 --savevectors=1 --predictions=out GRAPHLABSUBNETID/GRAPHLABSUBNETMASK environment variables not defined. Using default values Subnet ID: 0.0.0.0 Subnet Mask: 0.0.0.0 Will find first IPv4 non-loopback address matching the subnet Loading graph. Loading graph. Finished in 0.010117 Finalizing graph. Finalizing graph. Finished in 0.000114 FATAL: svd.cpp(main:716): Failed to load graph. Check your input path: A2

Please retake the latest from github and recompile.

Best,


User 94 | 3/7/2014, 9:25:33 AM

Yes I believe so myself, that the input files cannot be found. However, I pulled the latest version and I even reinstalled ubuntu and the dependencies to ensure no conflicts but I still get the same error. I have attached a print screen of terminal outputs.

We tested the same example using ubuntu in virutal box from windows 8 and the absurd result was that it worked. This leaves me to think that the failure probably is within the system and not in the toolbox. Thanks for the clarification! I will do a more thorough examination in the weekend, if I find something of interest I'll send you the info.

Regards Alexander


User 14 | 3/7/2014, 6:11:44 PM

Can you please try ./svd A2/A2 --rows=3 --cols=4 --nsv=3 --nv=4 --maxiter=3 --quiet=1 --savevectors=1 --predictions=out