Error when building the Graph_Analytics toolkit

User 639 | 9/3/2014, 1:08:41 AM

Hi, all

I'm new to graphlab. And when I'm trying to build the graph_analytics toolkit. Finally it gave the error below. I found that someone else has posted a similar discussion. I tried that to compile on a older version compiler(gcc4.6 and 4.7), but both failed. It's like during building the boost package. Can anyone give some suggestions? Thank you in advance.

[ 5%] Built target hadoop [ 12%] Built target libbz2 [ 17%] Built target boost [ 23%] Built target libevent [ 28%] Built target libtcmalloc [ 35%] Built target zookeeper [ 42%] Built target libjson [ 78%] Built target graphlab [ 83%] Built target eigen [ 83%] Built target TSC [ 83%] Built target approximatediameter [ 83%] Built target connectedcomponent [ 85%] Built target connectedcomponentstats [ 87%] Built target directedtrianglecount [ 89%] Built target eigenvectornormalization [ 89%] Built target formatconvert [ 91%] Built target graphlaplacian [ 92%] Built target kcore [ 94%] Built target pagerank [ 94%] Built target partitioning [ 96%] Built target simplecoloring [ 96%] Built target simpleundirectedtrianglecount [ 98%] Building CXX object toolkits/graphanalytics/CMakeFiles/sssp.dir/sssp.cpp.o In file included from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/proto/traits.hpp:24:0, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/proto/expr.hpp:27, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/proto/core.hpp:17, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/proto/proto.hpp:12, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/home/support/metacompiler.hpp:19, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/home/qi/metacompiler.hpp:14, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/home/qi/action/action.hpp:14, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/home/qi/action.hpp:14, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/home/qi.hpp:14, from /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/spirit/include/qi.hpp:16, from /home/yufeng/Documents/Research/graphlab/toolkits/graphanalytics/sssp.cpp:28: /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/lexicalcast.hpp: In instantiation of ‘struct boost::detail::deducesourcecharimpl<boost::detail::deducecharactertypelater<std::vector<long unsigned int> > >’: /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/lexicalcast.hpp:418:89: required from ‘struct boost::detail::deducesourcechar<std::vector<long unsigned int> >’ /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/lexicalcast.hpp:663:85: required from ‘struct boost::detail::lexicalcaststreamtraits<std::vector<long unsigned int>, std::basicstring<char> >’ /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/lexicalcast.hpp:2225:19: required from ‘static Target boost::detail::lexicalcastdocast<Target, Source>::lexicalcast_impl(const Source&) [with Target = std::basicstring<char>; Source = std::vector<long unsigned int>]’ /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/lexicalcast.hpp:2405:50: required from ‘Target boost::lexical_cast(const Source&) [with Target = std::basicstring<char>; Source = std::vector<long unsigned int>]’ /home/yufeng/Documents/Research/graphlab/deps/local/include/boost/programoptions/valuesemantic.hpp:198:73: required from ‘boost::programoptions::typedvalue<T, charT>* boost::programoptions::typedvalue<T, charT>::defaultvalue(const T&) [with T = std::vector<long unsigned int>; charT = char]’ /home/yufeng/Documents/Research/graphlab/src/graphlab/options/commandlineoptions.hpp:265:24: required from ‘voidHtml�I�M! ��7# ++����FYI: If you are using Anaconda and having problems with NumPyHello everyone,

I ran into an issue a few days ago and found out something that may be affecting many GraphLab users who use it with Anaconda on Windows. NumPy was unable to load, and consequently everything that requires it (Matplotlib etc).

It turns out that the current NumPy build (1.10.4) for Windows is problematic (more info here).

Possible workarounds are downgrading to build 1.10.1 or forcing an upgrade to 1.11.0 if your dependencies allow. Downgrading was easy for me using conda install numpy=1.10.1

Thanks for your attention!

RafaelMarkdown558,824,8414L���4L���179.110.206.156179.110.206.1564P�}��Xj�8\j�1str�"��\j�Xj��\j�8bj�րi�1(׀i��g��b�j����Xj�\j�Xj�8\j�1.hpp(decrementdistributedcounter:787): Distributed Aggregation of likelihood. 0 remaining. INFO: distributedaggregator.hpp(decrementdistributedcounter:793): Aggregate completion of likelihood Likelihood: -3.22336e+08 INFO: distributedaggregator.3HLABDISABLELAMBDA_SHM"] = "1" os.environ["GRAPHLABFORCEIPCTOTCP_FALLBACK"] = "1" import graphlab as gl

3. Test out your lambda worker code in this environment. If it works, then you can make the above configuration permanent by running:

gl.sys_util.write_config_file_value("GRAPHLAB_DISABLE_LAMBDA_SHM", "1")
gl.sys_util.write_config_file_value("GRAPHLAB_FORCE_IPC_TO_TCP_FALLBACK", "1")

Note that this can be undone by setting these to "0" instead of "1", or by editing the file given by gl.sys_util.get_config_file().

4. If the lambda workers do not work after trying step 1, then there are two things we would very much appreciate you do to help us track down the issue.

4.1. First, execute the following code in a clean python shell, where you have not yet imported graphlab create. At the end of this code, it prints out the path to a zip file that, if you could send it to us, will help us diagnose the issue. Please create a support tick^j�8bj�2�"��bj�^j��bj�8�j�րi�2(׀i����^j�8bj�2

Comments

User 6 | 9/3/2014, 5:59:42 AM

Hi, Please get the latest from github (using git pull) and then recompile. I have submitted a fix to solve this issue. The problem was with boost not detecting a type which is defined on runtime. Let us know if this works for you.

Please note that we have a newer Graph Analytics package a part of GraphLab Create: http://graphlab.com/products/create/docs/graphlab.toolkits.graph_analytics.html, with roughly the same functionality but easier access via the python interface.

Best,


User 639 | 9/3/2014, 1:07:09 PM

It does work for me. Thank you so much for help during the past two days.