import graphlab ImportError: Library not loaded: @rpath/libbase_dep.so

User 606 | 8/18/2014, 5:48:05 PM

Good afternoon,

had no issues with installing on my imac and macbook pro. My daily laptop (macbook air) is throwing the following upon import. All installs went without error. Any insights would be appreciated,

$ python -V Python 2.7.8 :: Anaconda 1.7.0 (x86_64)


ImportError Traceback (most recent call last) <ipython-input-1-4b66ad388e97> in <module>() ----> 1 import graphlab

/Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/init.py in <module>() 5 """ 6 ----> 7 import graphlab.connect.aws as aws 8 9 import graphlab.deploy

/Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/connect/aws/init.py in <module>() 3 This module defines classes and global functions for interacting with Amazon Web Services. 4 """ ----> 5 from ec2 import getcredentials, launchEC2, listinstances, setcredentials, status, terminateEC2

/Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/connect/aws/ec2.py in <module>() 15 16 import graphlab.productkey ---> 17 import graphlab.connect.server as glserver 18 import graphlab.connect.main as glconnect 19 from graphlab.connect.main import catchandlog

/Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/connect/server.py in <module>() 4 """ 5 ----> 6 from graphlab.cython.cyipc import PyCommClient as Client 7 from graphlab.cython.cyipc import getpublicsecretkeypair 8 from graphlabutil.config import DEFAULTCONFIG as defaultlocalconf

ImportError: dlopen(/Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/cython/cyipc.so, 2): Library not loaded: @rpath/libbasedep.so Referenced from: /Users/e13188/anaconda/lib/python2.7/site-packages/graphlab/cython/cy_ipc.so Reason: image not found

Comments

User 606 | 8/19/2014, 6:54:30 PM

Solved by creating a separate environment using conda.

conda create -n graphlab python=2.7 anaconda.

I also had to downgrade PIP to 1.4 version for some reason.


User 14 | 8/19/2014, 8:37:28 PM

I'm glad your problem is solved. Conda is not fully supported at this moment, but supporting Conda is on our roadmap.


User 9 | 9/12/2014, 5:04:55 AM

We have also seen this error on supported OS X if the pip install graphlab-create did not finish properly. Uninstalling and reinstalling resolved the issue.

error: <pre class="CodeBlock"><code>ImportError: dlopen(/Users/eliorar/graphlab/lib/python2.7/site-packages/graphlab/cython/cyipc.so, 2): Library not loaded: @rpath/libbasedep.so

Referenced from: /Users/tim/graphlab/lib/python2.7/site-packages/graphlab/cython/cy_ipc.so

Reason: image not found</code></pre>

fix: <pre class="CodeBlock"><code>uninstall graphlab-create pip install graphlab-create </code></pre>


User 972 | 11/22/2014, 4:33:57 PM

Hi I have the same problem, I tried your solution, It didn't work. Do you have any idea?


User 972 | 11/22/2014, 5:44:36 PM

I install all in windows and All installs went without error. Now I have the same error in import graphlab. Please guide me.


User 14 | 11/22/2014, 8:41:43 PM

Hi,

If you are using GraphLab Create in Windows, please follow this guide http://graphlab.com/products/create/virtual_install.html to use VM.

Thanks, Jay


User 1015 | 12/2/2014, 5:15:55 AM

I get the same error when trying to import. Uninstalling and reinstalling did not help. In both attempts for installing, while I was able to complete the installation I saw the following error:

xcrun: error: active developer path ("/Library/Developer/CommandLineTools") does not exist, use xcode-select --switch path/to/Xcode.app to specify the Xcode that you wish to use for command line developer tools (or see man xcode-select)

Can anyone help me fix this problem?


User 14 | 12/2/2014, 7:19:19 PM

@sonamsamat‌ Seems like you are having trouble with xcode commandline tools.

The error message suggest that you manually fix the path for xcode using use xcode-select --switch path/to/Xcode.app. Do you know where your Xcode.app is located?


User 1905 | 5/10/2015, 4:23:22 PM

timmuss's fix worked for me

pip uninstall graphlab-create pip install graphlab-create

I'm on Mac OSX Yosemite


User 2012 | 6/3/2015, 11:20:04 PM

I'm also having the same issue.

It looks like there is a dynamic library cy_ipc.so that is trying to make a syscall @rpath/libbase_dep.so which is not available.


User 91 | 6/4/2015, 7:45:36 AM