"[ERROR] No product key found," though the environment variable is set

User 493 | 7/22/2014, 5:29:19 PM

I've set the GRAPHLABPRODUCTKEY environment variable to my product key. I can <pre>import graphlab</pre>, but when I call any function I see...

<pre>[ERROR] No product key found. Please configure your product key by setting the [Product] section with 'productkey' key in /Users/change/.graphlab/config or by setting the environment variable GRAPHLABPRODUCT_KEY to the product key.</pre>

This ~/.graphlab/config file does not exist. Anyone else seen/fixed this issue?

Comments

User 91 | 7/22/2014, 9:34:21 PM

Can you create a ~/.graphlab/config file with

[Product] productkey="YOURPRODUCT_KEY"


User 400 | 8/15/2014, 7:16:14 PM

I tried the above command, but I get the error that it can parse the product key. I have a config file with the product_key info. Please advise how to fix the error. Thanks, Rohit


User 19 | 8/15/2014, 7:20:34 PM

Did you use single quotes around your product key? How many characters does your product key have?


User 400 | 8/16/2014, 2:53:31 AM

Double quotes. 38 characters including dashes.


User 9 | 8/26/2014, 10:55:43 PM

Hi @rohit‌ and @jonathan‌ . Sorry you are still having troubles. Here is a script to help set the GraphLab Product Key. Give it a try and let us know if it helps.

Before running Python, paste the following code into your terminal window and execute. Replace 1234 below with your product key.

mkdir -p ~/.graphlab && echo -e "[Product]\nproduct_key=1234" > ~/.graphlab/config && echo "Configuration file written") || echo "Configuration file not written"


User 972 | 11/22/2014, 2:24:02 PM

Hi, I received the product key. when I run it on cmd, I received "Configuration file not written". I install VM, Graphlab Create, Python 2.7.x. What is the problem that it can not insert my product key in a GraphLab Create configuration file?