GraphLab Create 0.3 released!

User 46 | 5/29/2014, 6:06:01 PM

Our newest installment scales graphs to disk with SGraph, rounds out SFrame operations with join, append, and sparse dictionary and dense vector support, and gives you the ability to use side features with our latest recommender model, factorization_model!

Upgrade to get all the new bits and see the full release notes here! http://graphlab.com/products/create/upgrade/

Comments

User 238 | 6/4/2014, 9:17:00 PM

I upgraded to 0.3 using sudo pip install graphlab-create==0.3 as suggested. The upgrade appears to work fine (the system say the upgrade was successful), however, after I restarted the ipython notebook using the command - ipython notebook --pylab=inline- I got the message shown below as part of (output) my code:

A newer version of GraphLab Create (v0.3) is available! Your current version is v0.2.0. You can use pip to upgrade the graphlab-create package. For more information see http://graphlab.com/products/create/upgrade.


User 6 | 6/27/2014, 5:57:45 AM

This is strange. Can you try "sudo pip uninstall graphlab-create" and then install 0.3 again? Let us know if the problem persists.

Thanks


User 421 | 7/2/2014, 8:19:36 PM

Is there a detailed and completed instruction to install and operate GraphLab on a Mac? I found some pieces by surfing around. I wonder there is one around. Thanks.


User 18 | 7/2/2014, 11:05:52 PM

The instructions are the same for Mac and Linux. You just need pip (and optionally virtualenv). You can do that using either brew or easy_install. Google 'mac pip' or 'mac virtualenv' for more directions. Once you have those, just follow instructions on our product page to install GraphLab Create: http://graphlab.com/products/create/upgrade/ . Let us know if you run into any specific problems.