Undefined symbol error using Graphlab-SDK

User 5297 | 6/17/2016, 1:41:39 PM

I'm trying the Belief Propagation code here: https://github.com/alonpal/Belief-Propagation, and I'm getting the following error. I've tried to build the Belief Propagation library (that is imported) with different versions of Graphlab-SDK (master branch, 1.10, 1.9, 1.6, 1.5 etc) but nothing worked.

I would appreciate any help.

Thanks.

import graphlab as gl

import belief_propagation as bp

[INFO] graphlab.cython.cy_server: GraphLab Create v1.10.1 started. Logging: /tmp/graphlab_server_1466169787.log

This non-commercial license of GraphLab Create is assigned to xxxxxxx and will expire on xxxxxxx. For commercial licensing options, visit https://dato.com/buy/.

---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-2-ca350ce5592f> in <module>()
----> 1 import belief_propagation as bp

ImportError: ./belief_propagation.so: undefined symbol: _ZTVN8graphlab9gl_sframeE

Comments

User 5300 | 6/17/2016, 6:00:03 PM

Hi yigitcankaya94,

This type of error usually occurs when there is a mismatch between the SDK version and GraphLab's. Please make sure that you have the latest release of GraphLab and the SDK. If the issue persists you can try to downgrade GraphLab to version 1.10. Which operating system do you have?

Best, Alon