import graphlab fails after update

User 5294 | 6/16/2016, 2:41:02 AM

I have graphlab installed in a virtualenv, OSX yosemite 10.10.5. I saw the message that graphlab 1.10.1 was available so I ran:

  • pip install graphlab-create --upgrade

Next when I run ipython and try to import graphlab I get a stacktrace ending with

  • ImportError: dlopen(/Users/dwatson/dato/env/lib/python2.7/site-packages/graphlab/cython/cyunity.so, 2): no suitable image found. Did find: /Users/dwatson/dato/env/lib/python2.7/site-packages/graphlab/cython/cyunity.so: unknown file type, first eight bytes: 0x7F 0x45 0x4C 0x46 0x02 0x01 0x01 0x00

So I tried to downgrade to a minimum working version:

  • pip install graphlab-create==1.8.3

This sort of works in that I can import graphlab from the ipython command line, however when I try to import graphlab from the ipython web notebook, it never returns. The star is visible in the left hand side indicating the kernel I busy. I see the license message in the terminal window where I started the notebook.

I'm working on the coursera machine learning specialty so it would be great getting this working again. I would rather not instal the dato installer or anaconda. I have enough package managers thanks (yeah pip is a package manager...)

TIA

Comments

User 2123 | 6/16/2016, 5:59:08 PM

When using virtualenv, older versions of pip will try and install a linux version of GLC in your Mac. To make sure this doesn't happen please upgrade pip then upgrade GLC to the latest version.