Error launching the service

User 2574 | 6/8/2016, 11:58:46 PM

env = gl.deploy.Ec2Config(region='us-west-2',instance_type='t2.micro',aws_access_key_id='xxxx', aws_secret_access_key='xxx') c = gl.deploy.ec2_cluster.create(name='blah',s3_path='xxx',ec2_config=env)

I have replaced 'xxxx' with suitable values.

I get the following error: Exception: Unable to successfully retrieve correct EC2 image to launch for this version. This could be a temporary problem. Please try again in a few minutes. If the problem persists visit https://dato.com/support for support options.

Comments

User 1178 | 6/9/2016, 5:08:33 PM

Hi Javia,

We do not support launching ec2_cluster into t2.micro instance. Can you try using a different instance. We support the following instance types:

m1.xlarge, m3.large, m3.xlarge, m3.2xlarge, m2.xlarge, m2.2xlarge, m2.4xlarge, hi1.4xlarge,hs1.8xlarge,c1.xlarge, c3.xlarge, c3.2xlarge, c3.4xlarge, c3.8xlarge, cr1.8xlarge,i2.xlarge, i2.2xlarge, i2.4xlarge, i2.8xlarge, cc2.8xlarge,g2.2xlarge, m1.large, d2.2xlarge, g2.8xlarge, cg1.4xlarge,r3.2xlarge, c3.large, d2.4xlarge, d2.8xlarge, cc1.4xlarge,d2.xlarge, r3.large, r3.xlarge, r3.8xlarge,


User 2574 | 6/9/2016, 6:02:50 PM

Thanks .. so i attempted m3.large and I get this: RuntimeError: Unable to start host(s). Please terminate manually from the AWS console.

However I can see on the aws console that the instance is running. So can I or not run a job?


User 2574 | 6/9/2016, 6:33:40 PM

Also I am going through some examples such as this: https://dato.com/learn/gallery/notebooks/boost-model-perf-parameter-search.html

ln[12]: How do I know that ec2_job is running on the cluster created via ln[10] and not on my local machine? Because when I am seeing this example: https://dato.com/learn/userguide/deployment/pipeline-example.html, I can see that a reference is made to the cluster created via the environment parameter in the job_ec2 variable.

Let me know if misunderstood how this works.

[Running the latest graphlab version 1.10]