Upgrade message on AWS installation for Graphlab 1.9 to 1.10

User 5190 | 6/4/2016, 1:42:08 AM

This message pops up when I import graphlab when working on the AWS installation

A newer version of GraphLab Create (v1.10) is available! Your current version is v1.9. You can use pip to upgrade the graphlab-create package. For more information see https://dato.com/products/create/upgrade.

is this something that I need to take care of or is it an administrator task - (I don't want to crash amazon and be attacked by angry drones) I tried the pip instructions but that produced a load of error messages. I need to know quite urgently.to work with confidence!

Cheers

Chris

Comments

User 91 | 6/4/2016, 5:48:27 AM

The message is nothing to worry about. It wants you to update to the latest version.

If you are working with a virtual environment then pip install graphlab-create --upgrade should get you upgraded to the newest version. If you aren't using virtual env then using sudo is required.

If you received error messages when upgrading, then can you paste the log you get here. That would help us diagnose.


User 5339 | 6/29/2016, 6:07:20 PM

I have tried pip install --upgrade graphlab-create several times. My terminal tells me that graphlab is already up to date and shows the correct version number (1.10.1). But, when I open the ipnb, it still tells me that I am using v1.8.5 and I need to update using pip! Please, help. I have tried to figure out to which directory the update should be installed with no avail.


User 5339 | 6/29/2016, 6:09:05 PM

It seems to be working now, but I have no idea why.