Installation fails because GraphlabCreate1.9 can not be found

User 5196 | 5/14/2016, 6:45:23 AM

During installation I get the following error;

Could not find a version that satisfies the requirement graphlab-create>=1.9 (from GraphLab-Create-License==1.9) (from versions: 0.1.0, 0.2.0, 0.3.0, 0.9.0, 0.9.1, 1.0, 1.0.1, 1.1, 1.2, 1.2.1, 1.3.0, 1.4.0, 1.4.1, 1.5.1, 1.5.2, 1.6, 1.6.1, 1.7.1, 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5) No matching distribution found for graphlab-create>=1.9 (from GraphLab-Create-License==1.9)

It looks like the server does not offer the 1.9 version?

How should I proceed?

Thanks in advance, Rob

Comments

User 9 | 5/14/2016, 3:05:46 PM

Hi Rob,

Dato 1.9 is available for installation using pip. https://pypi.python.org/pypi/GraphLab-Create/1.9. Sometimes a retry works. If not, please share some more information about your system.

What version of pip are you using? What operating system?

Tim


User 5219 | 5/23/2016, 10:33:09 AM

Hi Tim,

My problem is equal.

$ uname -a Linux 0520bbc49b5d 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x8664 x8664 x86_64 GNU/Linux It is a container Docker.

:~/notebooks$ pip -V pip 8.1.2 from /opt/ds/lib/python3.4/site-packages (python 3.4)

Thanks Krishna


User 5219 | 5/23/2016, 10:40:34 AM

Tim, I did have sucess only with 1.8.5 version.


User 5219 | 5/23/2016, 10:48:58 AM

Problem resolved.

I used command with sudo


User 5219 | 5/23/2016, 11:43:06 AM

With version 1.8.5.


User 5219 | 5/23/2016, 11:43:27 AM

Version 1.9 with problems.


User 5219 | 5/23/2016, 12:33:38 PM

$ pip3 install graphlab-create Collecting graphlab-create Using cached GraphLab-Create-1.8.5.tar.gz <<<<------- Here him redirect to 1.8.5 Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 1, in <module> File "/tmp/pip-build-amf4tzx0/graphlab-create/setup.py", line 87 print "" ^ SyntaxError: Missing parentheses in call to 'print'

----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-am f4tzx0/graphlab-create/

Not install version 1.9.


User 5219 | 5/23/2016, 12:45:50 PM

GraphLab is incompatible with python 3?


User 9 | 5/23/2016, 2:43:27 PM

Hi @agentelinux this explains your issue.

GraphLab Create for Python 3.4 is currently in beta. Please see this post for install instructions. http://forum.dato.com/discussion/1962/beta-support-for-graphlab-create-on-python-3-4#latest