model_parameter_search tmp file location

User 2785 | 4/13/2016, 9:30:36 PM

Hi there,

I'm attempting to tune my model via modelparametersearch and am running into an issue with where the tmp file gets located. When training a model via boostedtreesclassifier.create I'm able to assign the tmp file via gl.set_runtime_config('GRAPHLAB_CACHE_FILE_LOCATIONS', '/mnt/dato') however this doesn't appear to work for the modelparametersearch method - it instead defaults to my home dir. Any thoughts?

Here's where the output gets located:

` [root@dato home]# du -sh lisafeets/.graphlab/artifacts/*

[2:07] 12K lisafeets/.graphlab/artifacts/index

[2:07] 624M lisafeets/.graphlab/artifacts/Model-Parameter-Search-Apr-13-2016-20-43-0900000.Job

[2:07] 438M lisafeets/.graphlab/artifacts/Model-Parameter-Search-Apr-13-2016-20-50-0900000.Job

[2:07] 1.3G lisafeets/.graphlab/artifacts/results

[2:07] 4.0K lisafeets/.graphlab/artifacts/version `

Comments

User 19 | 4/13/2016, 10:18:03 PM

Hi wallawalla,

Unfortunately, that configuration parameter only controls the temporary files that are created while doing SFrame operations and modeling operations. The runtime configuration parameter that should be more appropriate for model_parameter_search artifacts is called GRAPHLAB_ARTIFACTS_TMP_SESSION_DIR.

Let us know if that helps! Chris


User 2785 | 4/14/2016, 2:23:31 PM

Yup, that works great!!

(churn_27)[lisafeets@dato boosted_trees]$ export GRAPHLAB_ARTIFACTS_TMP_SESSION_DIR=/mnt/dato/artifacts_tmp (churn_27)[lisafeets@dato boosted_trees]$ python hypertuning_boosted_trees.py 2016-04-14 14:22:15,850 [INFO] graphlab.deploy._session, 580: Using session dir: /mnt/dato/artifacts_tmp

Thanks, Chris!!