Need help! Failed to install GraphLab Create

User 4084 | 3/28/2016, 12:56:28 AM

Win 10 64-bit, Python 3.5.1

I tried to install GraphLab Create using the pip command, but it gave me an error:


Collecting graphlab-create>=1.8.5 (from GraphLab-Create-License==1.8.5) Downloading GraphLab-Create-1.8.5.tar.gz (46.1MB) 100% |████████████████████████████████| 46.1MB 2.8MB/s Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 1, in <module> File "C:\Users\ericw\AppData\Local\Temp\pip-build-2t77g00z\graphlab-create\setup.py", line 87 print "" ^ SyntaxError: Missing parentheses in call to 'print'

----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in C:\Users\ericw\AppData\Local\Temp\pip-build-2t77g00z\graphlab-create\

Comments

User 9 | 3/28/2016, 4:38:27 PM

Hi,

GraphLab Create can be installed on Python 2.7x. Python 3.5x is not yet supported but will be soon.

You can use Anaconda environments to easily install Python 2.7x or Python 3. Please see https://dato.com/download/install-graphlab-create-command-line.html for more details.

Tim


User 4084 | 4/6/2016, 7:58:57 PM

even if I installed Miniconda with python 2.7, the installation of GraphLab Create still failed and the same error message popped up.


User 940 | 4/6/2016, 9:45:52 PM

Hi @EWONG1086 ,

Is it possible that the pip from inside the conda environment is not the correct one? From inside the conda environment, could you type the command

which pip

This will give us more information.

Thanks!

Cheers! -Piotr


User 940 | 4/6/2016, 9:47:37 PM


User 4084 | 4/7/2016, 12:46:16 AM

i upgraded my setuptools using pip and now i've successfully installed the GraphLab Create. Thank you for your patience. :)


User 940 | 4/7/2016, 9:42:10 PM

@EWONG1086 ,

I'm happy you were able to install! Let us know if you have any other issues.

Cheers! -Piotr