unable to update glc to 1.8.5 from 1.8.1

User 2785 | 3/22/2016, 11:39:15 PM

trying to update graphlab to 1.8.5 but am getting the following error:

(dato_185)[lisafeets@dato dandelion]$ pip install --upgrade --no-cache-dir --trusted-host packages.prod.urbanairship.com https://get.dato.com/GraphLab-Create/1.8.5/EMAIL/KEY/GraphLab-Create-License.tar.gz /home/lisafeets/dandelion/dato_185/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning. InsecurePlatformWarning You are using pip version 7.1.0, however version 8.1.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Collecting https://get.dato.com/GraphLab-Create/1.8.5/EMAIL/KEY/GraphLab-Create-License.tar.gz /home/lisafeets/dandelion/dato_185/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning. InsecurePlatformWarning Downloading https://get.dato.com/GraphLab-Create/1.8.5/EMAIL/KEY/GraphLab-Create-License.tar.gz Collecting graphlab-create>=1.8.5 (from GraphLab-Create-License==1.8.5) Could not find a version that satisfies the requirement graphlab-create>=1.8.5 (from GraphLab-Create-License==1.8.5) (from versions: 1.8.1) No matching distribution found for graphlab-create>=1.8.5 (from GraphLab-Create-License==1.8.5)

any thoughts? I'm able to get 1.8.1. to work with the same pip install command

Comments

User 2785 | 3/23/2016, 4:46:40 PM

fixed by using PIPINDEXURL= before the rest of the command above