PowerGraph: Could not find AMI ami-e437a9d4

User 3736 | 3/18/2016, 7:55:12 AM

Hi, I am trying to deploying the powergraph in AWS EC2 Cluster following the instruction of your tutorial https://github.com/dato-code/PowerGraph/blob/master/TUTORIALS.md, I followed all the steps except that I ran an instance on us-east-1b while it's suggested to run on us-east-1a zone. I thought it might be ok. But When I tried to start the cluster, I typed this command: ./gl-ec2 -i ~/.ssh/MyFirstKeypair.pem -k MyFirstKeypair -r us-east-1a -s 1 launch launchtest . And I got the error : <Response><Errors><Error><Code>InvalidAMIID.NotFound</Code><Message>The image id '[ami-e437a9d4]' does not exist</Message></Error></Errors><RequestID>fd692adb-8fba-48b1-a134-22b1b2c2dce0</RequestID></Response> Could not find AMI ami-e437a9d4 And what can I do with this, thanks!

Comments

User 3736 | 3/20/2016, 10:59:44 AM

I've solved the problem by creating a new instance in the region us-west-2. I noticed that the default region in the python script file gl_ec2.py is us-west-2. So I thought that may be where the AMI is. Thanks anyway.