Install Graphlab Create on AWS for Coursera students

User 3437 | 3/10/2016, 6:30:37 PM

Dear colleagues, I am enrolled in "Classification" course of machine learning sequence offered by Univ. of Washington. I have already taken the first two courses, including course on Regression. I used AWS instances to finish all the assignments earlier. But, when I tried to Launch an instance for the new course, I am experiencing some difficulties. Luckily, I found some help on dato.com on how to install AWS Graphlab create.

In one of the installation steps, it says:

On the left navigation, select AMI's.

But when I saw carefully on the left navigation, I saw the options; my AMI's, Community AMI's. Here, I am confused which one shall I choose now.

Next step says: Choose Public images from search dropdown.

But since I was not sure to select the proper AMI's, I am not very convinced, what is meant by this step. I recall earlier while completing "Regression course", this step was not required. Therefore these two steps seem to be new.

I will be really grateful, if any assistance can be provided my the members here. Thank you.

Comments

User 954 | 3/10/2016, 10:49:30 PM

Dear Colleague,

You are right. Instructions need to be updated. Can you find the graphlab image (graphlab-create-1.8.4-coursera) in Community AMI's and then follow the rest of instructions ? (I was able to find it)

Thanks for helping us to improve the product. Emad


User 9 | 3/10/2016, 11:48:15 PM

Hi @jayant

You are correct. It appears that AWS is doing some A/B testing on their UI. I recently noticed the change on the AWS website and updated the instructions on dato.com. Now I see that the AWS UI is back to the original state. Thanks for letting us know.

Tim


User 3437 | 3/11/2016, 1:58:32 AM

Hello Gentlemen, Thanx for the help.It worked for me.I was able to access course 3 notebook, which is on Classification. I just have couple of more questions:

First, since I searched for graphlab-create-1.8.4-coursera in the community AMI's, I feel that I do not need to upgrade graphlab anymore once I am able to open the notebook.Please let me know, if I am wrong.

Next, the product key, which I had earlier from the Regression class, will that work here also in this new version of graphlab? Thanks for the assistance.

Best.


User 15 | 3/11/2016, 7:07:05 PM

Yes, GLC should be at 1.8.4 in that AMI. You can always check with graphlab.version to make sure though.

Yes, the earlier product key will work.


User 3437 | 3/11/2016, 10:49:24 PM

Thanks for the reply,Sir.

I noticed a strange thing about thois new version of graphlabcreate.. Whenever I am running the command:

products = graphlab.SFrame('amazon_baby.gl/')

I get the message, "the kernel seems to have died."

I tried to restart kernel several times, but no progress. I launched a new instance, still the same issue. I will really appreciate, if this issue can be looked into and any advice will be greatly appreciated.

thanks


User 1207 | 3/14/2016, 9:26:41 PM

Hello @jayant,

We're looking into this issue now. The reason for it is extremely deep -- essentially it seems to be a bug in one of the libraries that ipython notebook depends on, and we're working on a fix. Expect to hear back from us soon on it.

Thanks! -- Hoyt


User 3613 | 3/16/2016, 12:02:27 AM

I had the same problem with kernel death. Graphlab version 1.8.4 Coursera. AMI On 1.8.3 ver, everything is OK


User 1190 | 3/17/2016, 7:55:43 PM

Sorry to hear that you have trouble with v1.8.4. We are working on a bugfix release to help solve the issue. Until then, please stay with 1.8.3.