Installation error jsonschema

User 3380 | 3/9/2016, 2:26:56 PM

Hi,

I'm working with a Kubuntu 14.04 OS. Apparently I am not able to install GraphLap on my computer because as soon as i type in terminal pip install --upgrade --no-cache-dir https://get.dato.com/GraphLab-Create/1.8.3/.../GraphLab-Create-License.tar.gz installs up to jsonschema-2.5.0.tar.gz then i does not continue and finally not installed. Could you please indicate me where my error is? Many thanks in advance

Comments

User 15 | 3/9/2016, 7:10:50 PM

This looks pretty strange to me. It looks like the failure came from some network problems. However, when I install jsonschema==2.5.0, the vcversioner package is not attempted, though your log seems to show that vcversioner is considered a requirement for jsonschema. I am able to resolve the URL that your log fails on from my location as well, and pip installs vcversioner and jsonschema for me on Xubuntu 14.04.

Are you possibly having network issues where you are? Can you resolve "https://pypi.python.org/simple/vcversioner/" in your browser?


User 3380 | 3/10/2016, 9:49:49 AM

Many thanks your guidance was useful to finally solve the problem. Thanks a lot,


User 15 | 3/10/2016, 7:41:21 PM

Glad to hear it. Could you share what you did to fix the problem, in case others run in to the issue?


User 2448 | 3/30/2016, 2:53:18 PM

I encountered the same problem as this poster, the way I resolved it was to run the following commands:

pip --upgrade install vcversioner pip --upgrade install jsonschema==2.5.0 pip --upgrade install graphlab-create

For some reason, jsonschema's installer hung when installing the vcversioner dependency, but when I did it manually, it worked.

It's worth noting that I'm behind a corporate proxy, so in all of the above commands I actually had to pip --proxy=myusername:mypassword@myproxy:myport --upgrade install etc.