Unable to complete creation of conda envinroment "dato-env".

User 3254 | 2/28/2016, 7:36:27 PM

i first install anaconda , then i try to install Dato launcher many time , but it is showing error "Unable to complete creation of conda envinroment "dato-env". what can i do now?

Comments

User 9 | 2/29/2016, 6:05:41 PM

Hi @anuj1uee.

I think you might be hitting a bug. The conda commands the Dato Launcher depends on apparently has a known issue in newer versions of Anaconda (ver >2.4.1) on OSX. Since the Dato Launcher is trying to install into your existing Anaconda installation versus installing Anaconda itself, this might be the case.

First, check your Anaconda version, then try a workaround until we release an update to the Dato Launcher.

Check the existing version of Anaconda by executing python --version at the root of your shell. Versions >=2.4.1 on OSX will likely face this issue you are experiencing.

Workaround: You can manually create the conda environment 'dato-env' by executing the below command, then re-run the Dato Launcher to complete the installation.

conda create -n dato-env python=2.7 anaconda

Let me know if this works for you.

Tim