Latest version 1.8.3 of GraphLab does not display in 'ipynb'

User 3248 | 2/26/2016, 2:58:44 AM

I upgraded GraphLab to 1.8.3 and the inline canvas in Ipython Notebook does not work any longer. It does not show anything. I tried to change to 'browser' successfully. Going back to ipynb goes back to not working.

I tried a fresh uninstall/install, without success.

I uninstalled and installed the previous version 1.8.2, and now ipynb works again.

Anybody else experiencing this?

thanks mac

Comments

User 19 | 2/26/2016, 4:36:49 PM

Hi mac,

Sorry to hear this. Can you tell us what version of IPython you're using so that we can try to reproduce the issue? Also, can you provide a code snippet?

For me, operations like sf.show() show up inline with jupyter version 4.0.6 and GLC 1.8.3.

Cheers, Chris


User 3248 | 2/27/2016, 12:26:11 AM

import graphlab sales = graphlab.SFrame('homedata.gl/') # Of course do any SFrame creation graphlab.canvas.settarget('ipynb') sales.show(view="Scatter Plot", x="sqft_living", y="price")

jupyter core 4.0.6 py 1.4.31 anaconda 2.5.0 64bit GCC 4.4.7