GPU Acceleration on AWS Amazon Linux g2.2xlarge

User 3122 | 1/25/2016, 7:35:21 AM

I'm trying to use the GPU with graphlab create on an aws amazon linux g2.2xlarge that was built with the Nvidia AMI that had drivers included.

I installed graphlab then ran the following code to upgrade to the gpu acceleration on aws.

pip install --upgrade --no-cache-dir http://static.dato.com/files/graphlab-create-gpu/graphlab-create-1.8.gpu.tar.gz

Then I rebooted the machine just to be safe. However, if I run the following code to test if it is hitting the GPU I can see in the progress logs that it is NOT. What am I doing wrong?

data = graphlab.SFrame('http://s3.amazonaws.com/dato-datasets/mnist/sframe/train')
m = graphlab.neuralnet_classifier.create(data, target='label')

...

PROGRESS: Computing mean image... PROGRESS: Done computing mean image. PROGRESS: Creating neuralnet using cpu

Comments

User 940 | 1/26/2016, 4:42:31 PM

Hi @chipa,

Could you run nvidia-smi in the bash terminal and post the output? It could be a driver version problem.

Cheers! -Piotr


User 3122 | 1/27/2016, 7:33:59 PM

+------------------------------------------------------+
| NVIDIA-SMI 340.32 Driver Version: 340.32 |
|-------------------------------+----------------------+----------------------+ | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GRID K520 On | 0000:00:03.0 Off | N/A | | N/A 29C P8 17W / 125W | 10MiB / 4095MiB | 0% Default | +-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+ | Compute processes: GPU Memory | | GPU PID Process name Usage | |=============================================================================| | No running compute processes found | +-----------------------------------------------------------------------------+


User 3122 | 1/28/2016, 2:44:24 AM

Well that's annoying... so the default AMI nvidia published on the AWS marketplace is behind several versions. I will upgrade and try again.


User 3122 | 1/28/2016, 4:45:18 PM

Upgrading worked thanks.

For anyone having the same problem... If you install the nvidia AMI from the marketplace you will need to upgrade the driver to the latest version still. I followed the instructions here and it worked fine: http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/usingclustercomputing.html