Problem importing GraphLab Create on Python 2.7

User 3102 | 1/22/2016, 1:00:51 PM

Hi,

I've recently installed GraphLab Create on a Mac OS X system running El Capitan (10.11) and Python 2.7.10 (Anaconda). Upon attempting to import graphlab, however, I receive the following error:

>> import graphlab
Traceback (most recent call last):

  File "<ipython-input-1-4b66ad388e97>", line 1, in <module>
    import graphlab

  File "/Library/Python/2.7/site-packages/graphlab/__init__.py", line 55, in <module>
    import graphlab.connect.aws as aws

  File "/Library/Python/2.7/site-packages/graphlab/connect/aws/__init__.py", line 18, in <module>
    from _ec2 import get_credentials, list_instances, set_credentials

  File "/Library/Python/2.7/site-packages/graphlab/connect/aws/_ec2.py", line 21, in <module>
    import boto.ec2

  File "/Library/Python/2.7/site-packages/boto/ec2/__init__.py", line 26, in <module>
    from boto.ec2.connection import EC2Connection

  File "/Library/Python/2.7/site-packages/boto/ec2/connection.py", line 34, in <module>
    from boto.auth import detect_potential_sigv4

  File "/Library/Python/2.7/site-packages/boto/auth.py", line 34, in <module>
    import boto.utils

  File "/Library/Python/2.7/site-packages/boto/utils.py", line 52, in <module>
    import email.mime.multipart

ImportError: No module named multipart

This seems to be more of a placeholder error than anything though because immediately repeating the same command yields the next error:

>> import graphlab
Traceback (most recent call last):

  File "<ipython-input-2-4b66ad388e97>", line 1, in <module>
    import graphlab

  File "/Library/Python/2.7/site-packages/graphlab/__init__.py", line 54, in <module>
    import graphlab.connect as _mt

AttributeError: 'module' object has no attribute 'connect'

This is the persistent error I receive on every subsequent attempt. I originally installed the graphlab module via pip install graphlab-create and have tried uninstalling and reinstalling several times (following advice from @EvanSamanas and others on this thread: http://forum.dato.com/discussion/1284/importing-graphlab-in-ipython-error-attributeerror-module-object-has-no-attribute-connect and others). Installing/ upgrading multipart also has no effect as the second error will inevitably recur afterwards. Any ideas as to what could be causing this?

Any help would be greatly appreciated.

Many thanks,

Comments

User 3102 | 1/22/2016, 2:26:42 PM

Problem solved - didn't realise this works solely in an iPython environment. Apologies for the confusion.


User 1189 | 1/25/2016, 6:14:50 PM

Hi,

This should work even in regular Python. It looks like your Anaconda Python is mixing in imports from the regular Python on the system.

Make sure "which python" points to the right Python (whereever you installed Anaconda Python. And similarly "which pip" Otherwise you will want to run python (or pip) from [whereever you installed Anaconda]/bin/python.

Alternatively you can try the Dato Launcher which tries to set it all up for you.

Yucheng