cannot install SFrame using "pip install sframe"

User 3065 | 1/19/2016, 12:51:30 AM

I am getting the below error when I tried to install SFrame ; Collecting sframe Downloading SFrame-1.8.tar.gz (20.4MB) 100% |████████████████████████████████| 20.4MB 13kB/s Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 20, in <module> File "/tmp/pip-build-bnub5m7k/sframe/setup.py", line 83 print "" ^ SyntaxError: Missing parentheses in call to 'print'

Comments

User 1592 | 1/19/2016, 5:49:52 AM

Hi Please make sure you are using Python 2.7 and not Python 3. Thanks


User 2522 | 1/21/2016, 3:38:39 PM

I received the same error when attempting to install a Python3 environment. As Danny says, try to install into Python2.7. Support for 3 is forthcoming and hopefully will be along soon.

EDIT: I just installed Dato launcher 2.0.1 that is part of the product. The Python version is 3.4.3. It's on top of the Anaconda 2.4.0 release. The open source SFrame should soon be at Python3 soon if it is not already.


User 2522 | 1/24/2016, 8:28:10 AM

I'm wrong. I was in the other Anaconda install on my machine. I'm sorry for providing information to you that wasn't correct.


User 16 | 5/2/2016, 9:10:31 PM

@jpogah -

SFrame now support Python 3.4. You can install it via pip.