Cannot launch ipython notebook / terminal using Dato launcher 2.0.0

User 3041 | 1/16/2016, 11:01:44 PM

I upgraded dato launcher to 2.0.0 version and since then ipyhon notebook/terminal cannot be launched. It was working fine in the older version. selecting ipython notebook from dato launcher just opens and closes cmd terminal quickly.

Comments

User 3042 | 1/17/2016, 12:34:30 AM

I am getting the same issue. I just upgraded and now when launching, it pops up with the command line and quickly disappears and not launching the notebook.

Anybody has solution to this?


User 3044 | 1/17/2016, 7:29:27 AM

Same here, the terminal window pops up for a split second - then vanishes. Good that I have the old Dato environment running on another machine so I can continue to work until a solution for this problem is available.


User 3045 | 1/17/2016, 10:40:49 AM

Same issue here. I have just upgraded launcher to 2.0.0 Whatever I select 'Terminal' or 'IPython notebook' the command line window pops up for a second and then nothing happens. Previous version worked fine for me.


User 2288 | 1/17/2016, 11:58:35 AM

Same issue. I am stuck.


User 3046 | 1/17/2016, 12:04:42 PM

Same issue here. I cannot run the IPython or the terminal after the upgrade to 2.0.0


User 3048 | 1/17/2016, 12:57:43 PM

Same issue. Can't work on the Coursera assigments :(


User 3049 | 1/17/2016, 2:11:54 PM

Same Issue.


User 3044 | 1/17/2016, 2:26:31 PM

I found a workaround: 1. Uninstall the new "Dato Launcher" 2. Download and install the old version of the Dato Launcher from: http://static.dato.com/files/dato-launcher/dato-launcher-1.2.2.exe

After that I was able to use the Launcher and ipython notebook just like before, I hope that helps!


User 9 | 1/17/2016, 3:56:21 PM

Sorry the Dato Launcher 2.0 is behaving this way for you. We are looking into it and can push a fix automatically without uninstalling.

Can you please share what OS and version you are using? Is the issue only after upgrade of did anyone experience with a new install of Dato Launcher 2.0?

Please try this work-around.

After you have installed Dato Launcher 2.0, you can use command line to start ipython or ipython notebook. The Dato Launcher 2.0 installs the necessary packages, including GraphLab Create, in a conda environment called 'dato-env'.

1-open a new terminal (without using the Dato Launcher) 2-execute the following in shell to activate the conda environment where Dato Launcher installs GraphLab Create and Python dependencies.

Windows activate dato-env

Mac: source activate dato-env

At this point, you can use GraphLab Create in terminal using ipython or in an IPython Notebook.

Terminal: execute ipython in terminal, then in ipython execute import graphlab.

IPython Notebook: executeipython notebook in terminal, then in a notebook cell execute 'import graphlab'. IPython Notebook sets the root directory in the UI to the working directory from which it was initiated. You can navigate to any directory on your system before executing 'ipython notebook'.

Let me know if this works for you. Tim


User 3051 | 1/17/2016, 4:53:02 PM

I have the same issue as well. I am using Win7 64bit. Please test the new version on this platform as well.

In addition, for the 2.0.0 version, it seems that we can change the install directory. However, it could not.


User 3046 | 1/17/2016, 5:33:03 PM

Dear Tim,

The work around worked for me.

Thank you


User 3052 | 1/17/2016, 7:00:27 PM

I'm having this issue as well. Using Windows 10 64bit.

The workaround works for me. I got a little confused on the "execute <code>ipython notebook</code> in terminal" step as I was trying to type it in the python environment. In case anyone else is as oblivious as I am, you have to open a new cmd terminal (or exit the python environment in the original?) before executing <code>ipython notebook</code>


User 9 | 1/17/2016, 7:11:46 PM

@Nathanm Correct. Open a new cmd terminal, then execute ipython notebook in shell. Calling 'ipython notebook' from within ipython or python won't succeed.


User 3052 | 1/17/2016, 7:20:13 PM

One update to what I said: It seems that you have to exit the python environment and run <code>ipython notebook</code> from within the same terminal the other steps were executed. When I opened a new terminal and opened the notebook, I was getting errors importing graphlab in the notebook.

Thanks a bunch Tim!


User 3054 | 1/17/2016, 8:18:33 PM

I have the same problem. Just installes 2.0.0. I work with Windows 10. Versio 1,2.2 worked perfect.

I will try the work-around.


User 9 | 1/17/2016, 8:42:31 PM

We have just posted an update to the Dato Launcher (2.0.1). The new version includes a fix for this issue described above.

To get the latest version, let Dato Launcher 2.0 update automatically. OR you can prompt an update by using the "Check for update" feature found in the Dato Launcher menu bar. We will be updating the file on dato.com shortly.

Please do try the update and let me know if your issue has been resolved. Thanks for all your help.


User 3057 | 1/18/2016, 6:36:04 AM

Dato launcher is not working properly, until the dato team fix this bug please open cmd and type ipython notebook. It will open the web browser


User 3045 | 1/19/2016, 11:12:08 AM

Tim,

The workaround works perfectly fine.

I run Windows 10 64-bit (Version 10.0.10240) and the issue has occurred when I did the upgrade, I tried to uninstall and install it again but it did not help.

Just a quick update: the launcher has been just updated to version 2.0.1 which solved the issue permanently for me, well done folks!

Best regards,

Grzegorz


User 3074 | 1/19/2016, 5:38:04 PM

iPython notebook just opens a firefox browser at http://localhost:8888/tree, that is completely blank. Python works fine in the terminal window, but no notebook. Any suggestions as to what I'm doing wrong?


User 9 | 1/19/2016, 5:47:48 PM

Hi @dgpdgpda, might be a bug in IPython Notebook or some setting in your Firefox.

Can you try to open IPython Notebook again and then cut-n-past the URL (http://localhost:8888) in a different browser, like Chrome? Or even incognito in Firefox. This could help determine if it is a browser-related issue.


User 3072 | 1/19/2016, 7:01:18 PM

Hi I just filed a ticket 827898 of the above problem. Please solve this. Also I try "ipython notebook" and get the attached errors upon doing "import graphlib". I'm going to now try resorting to a previous user's suggestion and uninstall 2.0.1. and install an older version.


User 3072 | 1/19/2016, 7:09:52 PM

Quick update to my previous post. I guess I had forgotten the "activate dato-env" step. Now "import graphlib" works. But please fix the dato launcher issues. Thanks.