Problems launching IPython notebook

User 3009 | 1/12/2016, 9:16:27 PM

Hi,

I'm trying to install GraphLab Create and IPython Notebook for use during a course in machine learning on Coursera. I have installed the "Dato Launcher" and when I start it it looks fine with a text that says "Launch a Python environment to use GraphLab Create", and two buttons to press. The right one says "IPython Notebook" but when i press it only a command promt opens and I can see that there is some sort of error that says: ...\Dato\Dato Launcher\lib\json\encoder.py", line 270, in interencode return _interencode(o, 0) UnicodeDecodeError: 'utf8' codec can't decode byte 0xe4 in position 17: invalid continuation byte"

And then it says "Welcome to the graphlab create terminal..." If I then again write

ipython notebook

the same error message shows up and it starts over again. I don't know if I'm missing something but I thougt it was supposed to open a kind of graphical file brower when opening the ipython notebook? My computer is running Windows 8, 64 bit. My computer has swedish as selected language, since the error seems to have something to do with decoding letters I thought it might be relevant.

I would be very grateful for any help!

Comments

User 2535 | 1/12/2016, 10:00:53 PM

Hi @Frank_Black,

When you click IPython Notebook, the command prompt should open and a browser tab should also open in your default browser. If the browser tab is not also opening, could you try switching the language to English and let us know if you're still seeing the problem. That will help us isolate whether the selected language is causing the problem.

Thanks. Jon


User 3018 | 1/13/2016, 1:01:32 PM

Hi!

I have the same problem as Frank_Black (same error). My computer is on Windows 10, usually in French, but I did as you suggested and changed the language settings to English: it didn't change a thing. Still the console opening instead of the ipython notebook, with the utf error.

So I installed the ipython notebook independently from the dato launcher, and it works fine as long as I'm launching it from a Windows Command Prompt and not your software... So is there a way to get GraphLab create independently from your DatoLauncher?

Thanks, Orange


User 2535 | 1/13/2016, 4:02:12 PM

Hi @Orange,

Thanks for confirming. We'll look into this. To answer your question, yes, you can install GraphLab Create using pip, following the instructions here: https://dato.com/download/install-graphlab-create-command-line.html

Thanks. Jon


User 2535 | 1/13/2016, 4:28:07 PM

Hi @Orange and @Frank_Black,

The problem might be due to having a non-ASCII character in the username in the installation path. Python doesn't support non-ASCII characters in the installation path. As a workaround, you could create a new account on the computer that includes only ASCII characters, and then try installing again.

Let us know how it goes. Jon


User 3009 | 1/14/2016, 4:17:07 AM

Hi,

it was ideed the swedish characters in my computer account name that caused it. When I used another account that I have on this computer without any swedish characters it worked perfectly.

Thanks for your help!