Graphlab installation fails

User 3007 | 1/12/2016, 3:46:23 PM

When trying to install GraphlabCreate the final command fails giving the following error. Please help

pip install --upgrade --no-cache-dir https://get.dato.com/GraphLab-Create/1.7.1/@gmail.com/license/GraphLab-Create-License.tar.gz

Collecting https://get.dato.com/GraphLab-Create/1.7.1/***************@gmail.com/********license***********/GraphLab-Create-License.tar.gz
  Downloading https://get.dato.com/GraphLab-Create/1.7.1/***************@gmail.com/*******license*************/GraphLab-Create-License.tar.gz
Collecting graphlab-create>=1.7.1 (from GraphLab-Create-License==1.7.1)
  Downloading GraphLab_Create-1.7.1-cp27-none-win_amd64.whl (45.0MB)
Requirement already up-to-date: boto==2.33.0 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: prettytable==0.7.2 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: decorator==3.4.0 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: librato-metrics==0.4.9 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: awscli==1.6.2 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: multipledispatch>=0.4.7 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Collecting sseclient==0.0.8 (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
  Downloading sseclient-0.0.8.tar.gz
Collecting certifi==2015.04.28 (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
  Downloading certifi-2015.04.28-py2.py3-none-any.whl (373kB)
Requirement already up-to-date: requests==2.3.0 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: mixpanel-py==3.1.1 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: tornado==4.1 in c:\anaconda2\lib\site-packages (from graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: six in c:\anaconda2\lib\site-packages (from librato-metrics==0.4.9->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: rsa==3.1.2 in c:\anaconda2\lib\site-packages (from awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: botocore<0.74.0,>=0.73.0 in c:\anaconda2\lib\site-packages (from awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: docutils>=0.10 in c:\anaconda2\lib\site-packages (from awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: colorama==0.2.5 in c:\anaconda2\lib\site-packages (from awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: bcdoc<0.13.0,>=0.12.0 in c:\anaconda2\lib\site-packages (from awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: backports.ssl-match-hostname in c:\anaconda2\lib\site-packages (from tornado==4.1->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: pyasn1>=0.1.3 in c:\anaconda2\lib\site-packages (from rsa==3.1.2->awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: jmespath==0.5.0 in c:\anaconda2\lib\site-packages (from botocore<0.74.0,>=0.73.0->awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Requirement already up-to-date: python-dateutil>=2.1 in c:\anaconda2\lib\site-packages (from botocore<0.74.0,>=0.73.0->awscli==1.6.2->graphlab-create>=1.7.1->GraphLab-Create-License==1.7.1)
Installing collected packages: sseclient, certifi, graphlab-create, GraphLab-Create-License

Markdown`�I�M! ��7# ++����FYI: If you are using Anaconda and having problems with NumPyHello everyone,

I ran into an issue a few days ago and found out something that may be affecting many GraphLab users who use it with Anaconda on Windows. NumPy was unable to load, and consequently everything that requires it (Matplotlib etc).

It turns out that the current NumPy build (1.10.4) for Windows is problematic (more info here).

Possible workarounds are downgrading to build 1.10.1 or forcing an upgrade to 1.11.0 if your dependencies allow. Downgrading was easy for me using conda install numpy=1.10.1

Thanks for your attention!

RafaelMarkdown558,824,8414L���4L���179.110.206.156179.110.206.1564P�}��Xj�8\j�1str�"��\j�Xj��\j�8bj�րi�1(׀i��g��b�j����Xj�\j�Xj�8\j�1.hpp(decrementdistributedcounter:787): Distributed Aggregation of likelihood. 0 remaining. INFO: distributedaggregator.hpp(decrementdistributedcounter:793): Aggregate completion of likelihood Likelihood: -3.22336e+08 INFO: distributedaggregator.3HLABDISABLELAMBDA_SHM"] = "1" os.environ["GRAPHLABFORCEIPCTOTCP_FALLBACK"] = "1" import graphlab as gl

3. Test out your lambda worker code in this environment. If it works, then you can make the above configuration permanent by running:

gl.sys_util.write_config_file_value("GRAPHLAB_DISABLE_LAMBDA_SHM", "1")
gl.sys_util.write_config_file_value("GRAPHLAB_FORCE_IPC_TO_TCP_FALLBACK", "1")

Note that this can be undone by setting these to "0" instead of "1", or by editing the file given by gl.sys_util.get_config_file().

4. If the lambda workers do not work after trying step 1, then there are two things we would very much appreciate you do to help us track down the issue.

4.1. First, execute the following code in a clean python shell, where you have not yet imported graphlab create. At the end of this code, it prints out the path to a zip file that, if you could send it to us, will help us diagnose the issue. Please create a support tick^j�8bj�2�"��bj�^j��bj�8�j�րi�2(׀i����^j�

Comments

User 2535 | 1/12/2016, 6:35:17 PM

Hello @abhishek2689,

Could you try deleting this file C:\Users\abhisheka.graphlab\config and then re-running that command again? Let us know if that works.

Thanks. Jon


User 3007 | 1/14/2016, 4:17:44 AM

It worked. :)