unable to import graphlab, just runs without succeeding or terminating

User 2879 | 12/21/2015, 7:14:23 PM

i've used graphlab successfully for about a month and one day when I tried to run a python script it gets hung on the command 'import graphlab'. I don't even get an error, it just tries and tries without failing or succeeding to import. This happens in pycharm, the ipython notebook, as well as using python through the terminal. I've tried reinstalling graphlab. Any thoughts?

edit: using python 2.7 and windows 7

Comments

User 2156 | 12/21/2015, 7:48:20 PM

Hi spencerns,

Is this issue still persist? It is very likely the background process is still running while you run "import graphlab". Could you reboot your machine and then try it again?

Best,


User 2879 | 12/21/2015, 7:50:46 PM

Thanks for the quick response! i have rebooted a few times while trying to fix the issue, no luck!


User 2156 | 12/21/2015, 8:08:34 PM

What scripts were you running and got stuck?


User 2156 | 12/21/2015, 8:09:51 PM

If you hit ctrl-c when the code is stuck, could you paste the stacktrace here?


User 2879 | 12/21/2015, 10:07:49 PM

here's the output after ctrl+c:

>>> import graphlab forrtl: error (200): program aborting due to control-C event Image PC Routine Line Source kernel32.dll 0000000077B14AB3 Unknown Unknown Unknown kernel32.dll 0000000077AD5A4D Unknown Unknown Unknown ntdll.dll 0000000077C0B831 Unknown Unknown Unknown

here's what was being run when this happened the first time, is that what you wanted?

` eventobjects = [] x = 0 while x < 5: current = eventurls529.pop(0) eventobjects.append(five29.parse_event(current)) x += 1

sf = graphlab.SFrame(event_objects) res = sf.unpack('X1') res.show() `

i had all of these imported in some way or another

from urllib import urlopen from bs4 import BeautifulSoup import re import graphlab


User 2156 | 12/22/2015, 1:44:06 AM

Could you check if the following file exists?

C:\Users\yourusername.graphlab\artifacts\lock.lock

If it is there, delete it and you should be able to unblock "import graphlab"


User 2879 | 12/22/2015, 6:47:03 PM

i deleted the empty folder lock.lock, but no luck


User 2879 | 12/22/2015, 7:09:20 PM

i got it working through a proper reinstallation. I realized i reinstalled graphlab under the wrong compiler, not the one I was using.

Thanks for your help kaiyu! I really appreciate it :)


User 2156 | 12/22/2015, 7:25:27 PM

Glad you resolved the problem!


User 2879 | 12/26/2015, 8:37:07 PM

the problem happened again and I realized that it was the lock.lock folder that was actually causing the problem! thanks again


User 2156 | 12/27/2015, 1:36:45 AM

Glad you are resolving the problem!


User 2941 | 1/2/2016, 6:01:32 AM

Hi All,

Exactly the same thing is happening with me.. Everything was fine for a month. Then SFrame starts having issues.. I am unable to use ipython notebook after using SFrame command. Everthing after using SFrame comes with an asterix (*) sign in the left and doesn't execute. Attaching the screenshot.

The problem started when I tried to read csv file from my local disk. Please help - struggling from past few days.

Reinstalling Dato Launcher also didn't help.

Attaching the screenshot of my system environment (Win 7 64 bit) and log.

Many thanks,

Jain

Below are the environment details of my machine - Windows7 O/S

{'ALLUSERSPROFILE': 'C:\ProgramData', 'APPDATA': 'C:\Users\rjain\AppData\Roaming', 'CLICOLOR': '1', 'COMMONPROGRAMFILES': 'C:\Program Files\Common Files', 'COMMONPROGRAMFILES(X86)': 'C:\Program Files (x86)\Common Files', 'COMMONPROGRAMW6432': 'C:\Program Files\Common Files', 'COMPUTERNAME': 'W7IN00800489L', 'COMSPEC': 'C:\Windows\system32\cmd.exe', 'DEFLOGDIR': 'C:\ProgramData\McAfee\DesktopProtection', 'FPNOHOSTCHECK': 'NO', 'GITPAGER': 'cat', 'HOMEDRIVE': 'C:', 'HOMEPATH': '\Users\rjain', 'IPYINTERRUPTEVENT': '752', 'JPYINTERRUPTEVENT': '752', 'JPYPARENTPID': '1240', 'LOCALAPPDATA': 'C:\Users\rjain\AppData\Local', 'LOGONSERVER': '\\WSIN00803', 'MYSAPGUIUSELANGUAGE': 'EN', 'NUMBEROFPROCESSORS': '4', 'OS': 'WindowsNT', 'PAGER': 'cat', 'PATH': 'C:\Program Files\Java\jdk1.7.051\bin;C:\Program Files (x86)\MySQL\MySQL Utilities 1.3.6\;C:\Microsoft SQL Server Migration Assistant for MySQL\bin\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files (x86)\WebEx\Productivity Tools;C:\Program Files\1E\NomadBranch\;C:\Windows\System32;C:\Program Files (x86)\IDM Computer Solutions\UltraEdit\;C:\Users\rjain\AppData\Local\Box\Box Edit\', 'PATHEXT': '.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC', 'PHPFCGIMAXREQUESTS': '0', 'PLMVIS82LIBPATH': 'C:\Program Files (x86)\SAP\FrontEnd\SAPgui\Program', 'PROCESSORARCHITECTURE': 'AMD64', 'PROCESSORIDENTIFIER': 'Intel64 Family 6 Model 58 Stepping 9, GenuineIntel', 'PROCESSORLEVEL': '6', 'PROCESSORREVISION': '3a09', 'PROGRAMDATA': 'C:\ProgramData', 'PROGRAMFILES': 'C:\Program Files', 'PROGRAMFILES(X86)': 'C:\Program Files (x86)', 'PROGRAMW6432': 'C:\Program Files', 'PSMODULEPATH': 'C:\Windows\system32\WindowsPowerShell\v1.0\Modules\', 'PUBLIC': 'C:\Users\Public', 'SESSIONNAME': 'Console', 'SSMAM2SSEPHOME': 'C:\Microsoft SQL Server Migration Assistant for MySql Extension Pack\', 'SYSTEMDRIVE': 'C:', 'SYSTEMROOT': 'C:\Windows', 'TEMP': 'C:\Users\rjain\AppData\Local\Temp', 'TERM': 'xterm-color', 'TMP': 'C:\Users\rjain\AppData\Local\Temp', 'UATDATA': 'C:\Windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77', 'USERDNSDOMAIN': 'APA.GAD.SCHNEIDER-ELECTRIC.COM', 'USERDOMAIN': 'APA', 'USERDOMAINROAMINGPROFILE': 'APA', 'USERNAME': 'rjain', 'USERPROFILE': 'C:\Users\rjain', 'VBOXINSTALLPATH': 'C:\Program Files\Oracle\VirtualBox\', 'VSEDEFLOGDIR': 'C:\ProgramData\McAfee\DesktopProtection', 'WINDIR': 'C:\Windows', 'WINDOWSTRACINGFLAGS': '3', 'WINDOWSTRACING_LOGFILE': 'C:\BVTBin\Tests\installpackage\csilogfile.log'} 0 ·


User 91 | 1/2/2016, 6:40:40 PM

Do you have a commercial or a non-commercial license? If so, it seems the license has expired and you need to extend your license period (if your use is non-commercial). Contact support@dato.com for more info on this.