Unable to upgrade graphlab version to 1.7.1

User 2485 | 12/5/2015, 4:11:41 PM

$ pip install graphlab-create==1.7.1 Collecting graphlab-create==1.7.1 Using cached GraphLab-Create-1.7.1.tar.gz Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 20, in <module> File "/private/var/folders/r4/ym8vk7tj7zd6pktdcsd4dnbc0000gn/T/pip-build-6uccm0ma/graphlab-create/setup.py", line 87 print "" ^ SyntaxError: Missing parentheses in call to 'print'

----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/r4/ym8vk7tj7zd6pktdcsd4dnbc0000gn/T/pip-build-6uccm0ma/graphlab-create

Comments

User 1207 | 12/5/2015, 5:57:02 PM

Hello sidz,

It appears you are trying to install GLC with python 3, which is currently unsupported. We're working on python 3 now, but you need to use python 2.7 currently.

Thanks! -- Hoyt


User 2485 | 12/27/2015, 7:02:36 PM

hoytak, how do I ensure I try to uprgae into 2.7 and not python 3? I have followed instructions from https://dato.com/download/install-graphlab-create-command-line.html and still get this error, do the steps 1 and 2 not ensure we stay within 2.7?

Step 1: Ensure Python 2.7.x Step 2: Ensure pip version >= 7


User 9 | 12/29/2015, 6:08:28 AM

Hi @sidz77,

Are you using anaconda?

The easiest way we find to define the version of Python to be installed is by using anaconda. With anaconda, it is possible to have Python 2.7 and Python 3 installed on the same machine in isolated conda environments. You can download anaconda here: https://www.continuum.io/downloads

Once anaconda is installed, follow the instructions on https://dato.com/download/install-graphlab-create-command-line.html to install GraphLab Create.

Here is the snip of the instructions that creates a Python 2.7 environment within anaconda.

`

Create a new conda environment with Python 2.7.x

conda create -n dato-env python=2.7 anaconda ` Make sure you activate this environment before installing GraphLab Create.


User 16 | 5/2/2016, 9:07:06 PM

@sidz77 -

GraphLab Create now has beta support for Python 3.4. See details here: http://forum.dato.com/discussion/1962/beta-support-for-graphlab-create-on-python-3-4