can't import graphlab

User 2667 | 11/24/2015, 11:08:00 PM

Hi all,

I use python2.7 on top of window 8, I follow exactly same with the 'how to Install GraphLab Create' from https://dato.com/download/install-graphlab-create-command-line.html, however, get an error, which is shown below, when I import graphlab: I've spent several hours on this but still couldn't figure it out. Please help! Thanks.

Comments

User 15 | 11/25/2015, 6:35:33 PM

This can sometimes happen when the Linux version is erroneously downloaded from PyPI. To confirm whether or not this happened, check if this file exists: c:\python27\lib\site-packages\graphlab\libunity_shared.so . If it does, you have the Linux version.

What is your version of pip? We require pip >= 7, as older versions of pip don't know what wheels are, and will just download the Linux version by default, no matter what your OS is.

If you are using pip 7, we have also seen PyPI spuriously delivering the Linux version to Windows. Try uninstalling and reinstalling, and make sure the file it downloads for GraphLab Create has the string "win" in it.

Let me know if this doesn't solve your problem.