Can't open Canvas in AWS EC2 instance

User 2662 | 11/23/2015, 7:36:34 PM

When I execute sf.show() it shows following :

Canvas is accessible via web browser at the URL: http://localhost:52566/index.html

Opening Canvas in default web browser.

I try to follow the above address but its not accessible.I also tried to replace localhost with my public IP of the aws instance,but still no success.

I also followed this link : http://forum.dato.com/discussion/comment/1833 and found the port canvas is running on (44000) but I don't know how/where to run this command --

ssh -L <port>:localhost:<port> remote.server

as mentioned in the post linked above

Comments

User 2593 | 11/24/2015, 1:01:00 AM

Hi Pradeep,

Are you using ipython notebook by any chance? If so, can you please run graphlab.canvas.set_target('ipynb').

Let me know how that works. This will avoid the need to tunnel into your host machine.

Thanks!

Charlie


User 2836 | 12/16/2015, 6:59:23 AM

Charlie, set_target works if I don't want to open a new window. can you suggest a way out for accessing URL? (I am using GraphLab on AWS) Thanks.


User 1190 | 12/16/2015, 6:14:16 PM

Yes, it is possible.

  1. use settarget('headless', port=SOMEPORT)
  2. make sure SOME_PORT is open (tcp) in the security rule
  3. access via PUBLICIPOFYOURINSTANCE:SOME_PORT/index.html

User 4181 | 4/25/2016, 12:26:19 PM

@Jay Gu i edited security group inbound rule and added another port . Custom TCP Rule , TCP <port> 50000 source anywhere. but it is still not working. i even tried to telnet PUBLIC IP with this port. that is also not working... Thanks