Canvas not displayed inside Of IPython Notebook

User 2647 | 11/20/2015, 7:59:50 PM

Hi, I've set the target using the statement graphlab.canvas.set_target(ipynb). when i try to display the canvas inside ipythonNotebook, it is neither showing any error nor displaying the canvas i wanted. The canvas i was trying to display was the age column using command: sf['age'].show() Please help me out with this as soon as possible.

Comments

User 19 | 11/20/2015, 9:09:21 PM

Hi,

Sorry to hear you're having trouble with this. Can you say a bit more about the version of IPython and GraphLab Create that you're using, as well as information about your system, e.g. OS, etc?

Thanks, Chris


User 4718 | 4/14/2016, 10:45:14 AM

I have the same problem MacOSX El Captain Dato, Jupyter, Python2, No error messages, but the graph is not rendered.

  • I will show however in a new browser window with sf.show()

Cheers


User 4 | 4/15/2016, 7:08:42 AM

There is a known issue with GraphLab Canvas in IPython Notebook when using a notebook that has been executed with multiple versions of GraphLab Create (saved originally with a different version than the currently-executing version). Once the notebook is in this state, no Canvas output will render. If you are using a notebook downloaded from the dato.com gallery or Coursera, it's likely this notebook was created with a different version of GraphLab Create, and this issue will be in effect.

The workaround is the following:

  • Clear all output (In the menu, run Cell -> All output -> Clear).
  • Save and close the notebook.
  • Open the notebook again and execute it.

User 5385 | 7/18/2016, 12:45:53 AM

Workaround did not work for me. :(


User 5390 | 7/18/2016, 2:07:16 PM

Same problem here, and the workaround also did not work for me. (running windows 7 64-bit, tried both in Firefox and Chrome)


User 4 | 7/18/2016, 6:41:10 PM

Hi @ecocarlisle and @Jordi133, I tried to reproduce this issue with a simple example notebook:

import graphlab as gl gl.canvas.set_target('ipynb') sa = gl.SArray(range(100)) sa.show()

However, there, the plot renders fine in the notebook and nothing seems broken. Can you try that sample and tell me whether it works for you? If the above code sample works for you, please provide a code sample that doesn't work so I can investigate. If the above code sample doesn't work, please let me know more details of your system and installed packages so I can try to reproduce the issue: OS & version, browser & version, GraphLab Create version, and Jupyter Notebook version are all needed to reproduce this issue.


User 5390 | 7/18/2016, 7:39:16 PM

I've just tried this but it doesn't show the graph. Only printing out the value of the sa-variable does work so I suppose graphlab was loaded correctly.


User 4 | 7/18/2016, 7:43:05 PM

Hi @Jordi133, thanks for trying that! To help diagnose the issue, can you please provide:

  • Operating system & version
  • Web browser & version
  • Python version
  • GraphLab Create version
  • Jupyter Notebook version

User 5390 | 7/18/2016, 7:55:05 PM

Hi,

I'm running - windows 7 64b - Chrome version 51.0.2704.106 m

and using Jupyter as provided by the Coursera course "Machine Learning Foundations: A Case Study Approach". It shows the following details:

About Jupyter Notebook Server Information:

You are using Jupyter notebook.

The version of the notebook server is 4.2.0 and is running on: Python 2.7.11 |Anaconda 4.0.0 (64-bit)| (default, Dec 6 2015, 18:08:32) [GCC 4.4.7 20120313 (Red Hat 4.4.7-1)]

Current Kernel Information:

Python 2.7.11 |Anaconda 4.0.0 (64-bit)| (default, Dec 6 2015, 18:08:32) Type "copyright", "credits" or "license" for more information.

IPython 4.1.2 -- An enhanced Interactive Python. ? -> Introduction and overview of IPython's features. %quickref -> Quick reference. help -> Python's own help system. object? -> Details about 'object', use 'object??' for extra details.

gl.version yields 1.9

If you need any more information please let me know


User 4 | 7/18/2016, 8:07:58 PM

Hi @Jordi133, thanks for the info -- this will help us track down the problem. Can you provide one more detail -- what is the URL in the location bar, when you are running this notebook?


User 5390 | 7/18/2016, 8:08:47 PM

Hi, it's https://ailnqiwtzbtdjcygwctmbc.jupyterhub.coursera-notebooks.org/user/ailnqiwtzbtdjcygwctmbc/notebooks/Week%201/Untitled.ipynb?kernel_name=python2#

Edit: and thanks in advance and good luck :)


User 4 | 7/18/2016, 8:12:59 PM

Thanks @Jordi133, I think we have tracked down the problem and we'll be working on a fix.


User 4 | 7/19/2016, 2:21:33 AM

The issue seems to be that GraphLab Create prior to 2.0 does not load JavaScript in notebooks when the notebook is on an https URL.

The workaround is to remove the "s" from the url, so that it reads http://<rest of the url>. This should work for the Coursera notebooks and will allow Canvas plots to render with pre-2.0 versions of GraphLab Create.


User 5390 | 7/19/2016, 10:30:18 AM

This indeed works, thanks a lot!