How to use GraphLab in AWS with Jupyter in PC

User 2582 | 11/12/2015, 2:18:01 AM

I have 32-bit ubuntu in my laptop which is not supported by GraphLab. So I am using AWS. But I cannot import GraphLab in IPython Notebook (Jupyter) running on my laptop. Please suggest some solution

Comments

User 17 | 11/13/2015, 11:23:49 PM

Hey Amartya,

Sorry to hear you're having problems getting started. If you're using ec2 to install and run GraphLab you'll need to run IPython Notebook on the same ec2 instance.

These directions may be helpful https://dato.com/download/install-graphlab-create-aws-coursera.html

-Romero.


User 2582 | 11/15/2015, 6:30:41 AM

Thank you, Romero, for the reply. I also tried to use both Jupyter and GraphLab on the same EC2 instance, but I am stuck at Step 3b. The public IP address fails to connect always.


User 2612 | 11/15/2015, 11:51:22 PM

Romero, I am having the same problem as Amartya. thanks.


User 2612 | 11/16/2015, 3:07:46 AM

Also, if I already have Enthought Canopy installed (rather than Anaconda) will that create problems? I notice that when the notebook (Jupyter) it is in Canopy.


User 19 | 11/17/2015, 2:29:37 AM

Hi Amartya,

Did you make sure to do Step 2j, where you open the required port? Did you double check that you're using the latest public ip address that is shown in your AWS console?

Aram: Are you sure that you've used the AMI mentioned in these instructions? https://dato.com/download/install-graphlab-create-aws-coursera.html

Thanks, Chris


User 2612 | 11/29/2015, 11:50:51 PM

yes, I have used the link you show above and the contained instructions. I am still not able to browse to the public IP address. I guess no one else had this problem?


User 2718 | 12/2/2015, 4:47:21 PM

Hi everyone,

Even I am facing the same problem. I am not able to browse public IP address(Step3b). Hope someone will find a solution.


User 5231 | 5/25/2016, 7:59:21 AM

I am also facing the same problem - Unable to connect to the public ip address. I followed the steps mentioned in https://dato.com/download/install-graphlab-create-aws-coursera.html#_ga=1.256020175.518147815.1463632222 Could anyone please help?


User 2568 | 6/6/2016, 5:00:20 AM

FYI - I use Dato+Jupyter on on EC2 on a daily basis, so I can vouch that it works. I remember having a similar problem that was cause by 1) not having Jupyter automatically started at boot, 2) the Jupyter config not allowing remote connections.

My suggestion is first check that jupyter is working by ssh'ing into the server and

  • Check the jupyter process is running, i..e, ps -ef | grep jupyter
  • Run a local browser on the the EC2 instance and connect to Jupyter locally. You may need to install links or lynx ( depending on your O/S) so you can do this.

    sudo yum install links -y links http://localhost:8888

If this connect then jupyter is working ok and it's either the port is closed (which you said you had checked) or Jupyter config is preventing remote connection. .

If I remember correctly, you edit the file ~/.jupyter/jupyternotebookconfig.py and edit a few parameter. I think the key one is c.NotebookApp.ip = '*' c.NotebookApp.port = 8888

how I did not take notes on what I did so this is a guess based on looking at my config file.

If you read these notes it says

By default, a notebook server runs locally at 127.0.0.1:8888 and is accessible only from localhost. You may access the notebook server from the browser using http://127.0.0.1:8888.

and here it talk about how to set up access by a remote web server. I did not bother setting certfile, keyfile or password.