Trouble on Linux Installing Graphlib

User 2426 | 10/16/2015, 5:03:11 PM

I am using ubuntu 15.04 and have followed the installation instructions (option 1 - anaconda installed) and have tried a seperate dato-env and still was unable to get the command "import graphlib" to work inside python. I have tried many potential solutions identified in this forum and from other places on the internet. Please note I am using a linux ubuntu vmware virtual machine. I was able to get it to work the first time but I decided to reorganize my software stacks and distribute them across several different virtual machines and I have been unable to get it working since. I must have rebuilt the entire linux/anaconda/graphlib virtural machines several times and still no luck. I am not very familar with linux, so now I am trying to get it working in Windows 7. Can anyone provide some suggestions? thanks...

Comments

User 2426 | 10/16/2015, 5:37:56 PM

I now have the same problem in windows. I installed anaconada first - I didn't realize that dato launcher installed anacondo too - so I have just proceeded with the installations. I am getting an ImportError: no module namesd graphlib


User 1174 | 10/16/2015, 6:40:36 PM

Hello,

Did you installation succeed without an error? Can you verify that you are running the python from Anaconda (python 2.7) environment which was installed by Dato Launcher?

Using the pip from the Anaconda environment, can you see GraphLab-Create 1.6.1?


User 2426 | 10/16/2015, 7:46:39 PM

I do not think there was an error, but I can re-install to verify. I invoked ipython and ran python from the anaconda bin directory - they both indicate python version 2.7.10 and anaconda 2.3.0. When I do a pip list - I see graphLab-Create 1.6.1 and another file that indicates it is a license file for graphlab.


User 2426 | 10/16/2015, 8:50:17 PM

I now have installed on a totally different machine in windows 10. I have used the dato launcher installer only. I get the same result.


User 1174 | 10/16/2015, 9:02:30 PM

It seems like your installation is fine. Just to double check the name, can you try:

import graphlab


User 2426 | 10/16/2015, 9:33:27 PM

I have the import command working in one of the environments... but now it is looking for a csv file in a directory and it is not there... I think my some of my environment variables are not set up correctly. Not sure what I did, but I am sure when I first installed it I must have overwritten some paths... Anyway, I need to double check what is working and what is not. It appears I am by the first step.


User 2426 | 10/16/2015, 10:13:10 PM

thanks for the help... I hate to admit it but in the windows environments I was typing graphlib not graphlab..but I really messed up the environment variables in the linux environment.