SSL verification error when trying to create a Python 3 env

User 2317 | 10/12/2015, 11:46:15 AM

Hi, I installed GraphCreate using the Data App. As I also need to have a Python 3 env I tried to create such an env. (calling it 'snakes' - see below). However I see to have ssl verification issues .... has anybody come across this before and any suggestions please? I notice from the error message below that one of the packages it wanted to install (if it could connect!) was openssl: 1.0.1k-1 , so I am assuming that, if this is relevant, the Data install must come with an older openssl package? Thank you.

Davids-MacBook-Air:~ durpani$ conda create --name snakes python=3.5 Fetching package metadata: SSL verification error: [SSL: CERTIFICATEVERIFYFAILED] certificate verify failed (_ssl.c:590) .SSL verification error: [SSL: CERTIFICATEVERIFYFAILED] certificate verify failed (_ssl.c:590) .SSL verification error: [SSL: CERTIFICATEVERIFYFAILED] certificate verify failed (_ssl.c:590) .SSL verification error: [SSL: CERTIFICATEVERIFYFAILED] certificate verify failed (_ssl.c:590) . Solving package specifications: ............ Package plan for installation in environment /Users/durpani/.graphlab/anaconda/envs/snakes:

The following packages will be downloaded:

package                    |            build
---------------------------|-----------------
xz-5.0.5                   |                0         132 KB
python-3.5.0               |                0        12.7 MB
setuptools-18.3.2          |           py35_0         345 KB
wheel-0.26.0               |           py35_1          77 KB
pip-7.1.2                  |           py35_0         1.4 MB
------------------------------------------------------------
                                       Total:        14.7 MB

The following NEW packages will be INSTALLED:

openssl:    1.0.1k-1     
pip:        7.1.2-py35_0 
python:     3.5.0-0      
readline:   6.2-2        
setuptools: 18.3.2-py35_0
sqlite:     3.8.4.1-1    
tk:         8.5.18-0     
wheel:      0.26.0-py35_1
xz:         5.0.5-0      
zlib:       1.2.8-0  

Comments

User 16 | 10/13/2015, 6:13:02 PM

Hi Durpani -

GraphLab Create does not currently support Python 3. Sorry about that. It's something I'm actively working on it.

Thanks, Toby